One Click Search Suggestions In Unified Search Bar

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
17 days ago
13 days ago

People

(Reporter: Kenan, Unassigned)

Tracking

({access})

57 Branch
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 days ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171206182557

Steps to reproduce:

Can use ctrl-k, then the left/right arrow keys to change the search engine used in the separate search and address bar layouts.


Actual results:

When using the unified search bar, there are no keyboard shortcuts to switch between the search engines before hitting enter.


Expected results:

The keyboard shortcuts should be preserved even if you're not using the separated search bar.

Comment 1

17 days ago
Use Up/Down keys.
Component: Untriaged → Address Bar
Keywords: access
(Reporter)

Comment 2

17 days ago
If you have history results show up, that does not work.
(Reporter)

Comment 3

17 days ago
To clarify, you first have to scroll through the results before you get to choose the search engine. The results should be decoupled from the engine choice.
ALT+UP/DOWN should move directly to the search engines. Since there is a keyboard shortcut, I'm resolving as wfm, but feel free to post further feedback.

Fwiw, CTRL+k and then left/right doesn't change the engine for me in the separate bars layout...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 days ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 days ago
Yes that works. Thank you! I tried looking for a list of shortcuts, but was not able to find such a thing. Is there one?
There is a list at https://support.mozilla.org/en-US/kb/Keyboard%20shortcuts but I doubt it's complete
You need to log in before you can comment on or make changes to this bug.