Unable to disable submenus parents

VERIFIED DUPLICATE of bug 21870

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 21870
18 years ago
18 years ago

People

(Reporter: davidm, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When all of a menu's children are disabled, the menu should be disabled.
Similiarly disabling a menu should disable all of it's children. An example
where this is not working is the offline menu in the file menu.

Updated

18 years ago
Assignee: trudelle → saari
Target Milestone: M14

Comment 1

18 years ago
assigning to saari as p3 for m14.  In the meantime, the offline menu should be
removed, since it is not implemented and out for 'beta'.

Updated

18 years ago
QA Contact: beppe → claudius

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M14 → M15
Similarly for empty submenus, which can be present in bookmarks with empty
folders, or directly through someone's XUL.  I guess the test should look for
the first enabled item and disables the parent if it doesn't find one.
(Assignee)

Updated

18 years ago
Assignee: saari → pinkerton
Status: ASSIGNED → NEW
(Assignee)

Comment 3

18 years ago
Taking menu/popup bugs.

Updated

18 years ago
QA Contact: claudius → sairuh

Comment 4

18 years ago
Pink just took ownership of several menu-related bugs, most were already QAassigned to sairuh, I'm just making sure that they
all are now :-)
(Assignee)

Comment 5

18 years ago


*** This bug has been marked as a duplicate of 21870 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.