Closed Bug 1427510 Opened 2 years ago Closed 7 months ago

Permafailing browser/extensions/formautofill/test/browser/browser_editCreditCardDialog.js | check cc-exp-year - Got 2018, expected 2017

Categories

(Toolkit :: Form Autofill, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- disabled
firefox58 --- disabled
firefox59 --- affected

People

(Reporter: intermittent-bug-filer, Assigned: scottwu)

References

Details

Attachments

(1 file)

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/aa6fd6d2a7ce
Use current year as expiration year in credit card test to fix perma failure. r=permafail-fix a=permafail-fix
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/27037bf80310
Use current year as expiration year in credit card test to fix perma failure: fix eslint issue. r=eslint-fix a=eslint-fix
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/a0df091c3697
Disable perma failing browser_editCreditCardDialog.js until it gets fixed. r=permafail-fix a=permafail-fix
Hi Luke, I disabled browser_editCreditCardDialog.js because it permafailed. The test tries to enter the expired credit card at https://hg.mozilla.org/mozilla-central/annotate/36c1b89781b4/browser/extensions/formautofill/test/browser/head.js#l43 which succeeded until the end of 2017.

A still valid credit card caused failures in browser_creditCard_doorhanger.js:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=27037bf8031067aaea19e6879364bbf7215f1606&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-resultStatus=retry
Flags: needinfo?(lchang)
Summary: Intermittent browser/extensions/formautofill/test/browser/browser_editCreditCardDialog.js | check cc-exp-year - Got 2018, expected 2017 → Permafailing browser/extensions/formautofill/test/browser/browser_editCreditCardDialog.js | check cc-exp-year - Got 2018, expected 2017
Duplicate of this bug: 1427592
Looks like if you fix test_saveCreditCard to:
let win = window.openDialog(EDIT_CREDIT_CARD_DIALOG_URL, null, null, TEST_CREDIT_CARD_1);

You get the following:
GECKO(13889) | JavaScript error: file:///.../dist/bin/components/crypto-SDR.js, line 136: NS_ERROR_FAILURE: Couldn't decrypt string
Console message: [JavaScript Error: "NS_ERROR_FAILURE: Couldn't decrypt string" {file: "file:///.../dist/bin/components/crypto-SDR.js" line: 136}]

This makes the test timeout.
Assignee: nobody → scwwu
Thanks for filing this bug and helping identifying the cause. Scott will follow up this issue.
Flags: needinfo?(lchang)
Comment on attachment 8941016 [details]
Bug 1427510 - Use current year as expiration year in credit card test case to fix perma failure.

https://reviewboard.mozilla.org/r/211310/#review217436

::: browser/extensions/formautofill/test/browser/head.js:110
(Diff revision 2)
>  
>  const TEST_CREDIT_CARD_2 = {
>    "cc-name": "Timothy Berners-Lee",
>    "cc-number": "1111222233334444",
>    "cc-exp-month": 12,
>    "cc-exp-year": 2022,

Not sure what `2022` will be used for but I think we shouldn't hardcode this number, either. Besides, I think we also need to test the upper bound of "cc-exp-year" in the dialog in Preferences.
Attachment #8941016 - Flags: review?(lchang)
Comment on attachment 8941016 [details]
Bug 1427510 - Use current year as expiration year in credit card test case to fix perma failure.

https://reviewboard.mozilla.org/r/211310/#review217436

> Not sure what `2022` will be used for but I think we shouldn't hardcode this number, either. Besides, I think we also need to test the upper bound of "cc-exp-year" in the dialog in Preferences.

Thanks for the suggestion. I changed the test case to the maximum year (+10 years), and added a test case to make sure it could be entered into the dialog.
Comment on attachment 8941016 [details]
Bug 1427510 - Use current year as expiration year in credit card test case to fix perma failure.

https://reviewboard.mozilla.org/r/211310/#review218456

Thanks.
Attachment #8941016 - Flags: review?(lchang) → review+
Keywords: checkin-needed
Pushed by lchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/93fa34d5492c
Use current year as expiration year in credit card test case to fix perma failure. r=lchang
Keywords: checkin-needed
Flags: needinfo?(lchang) → needinfo?(scwwu)
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d6ef6b74bfa
Use current year as expiration year in credit card test case to fix perma failure. r=lchang
Keywords: checkin-needed

I guess we fixed it

Status: NEW → RESOLVED
Closed: 7 months ago
Keywords: leave-open
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.