Closed Bug 1427591 Opened 2 years ago Closed 2 years ago

viewSource.xul are using an out of date API

Categories

(Thunderbird :: General, defect)

57 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1163707

People

(Reporter: musiquegraeme, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171206182557

Steps to reproduce:

In error console I click on the link to open the js file with the error.


Actual results:

The page is opened but this error is also given
DEPRECATION WARNING: The arguments you're passing to viewSource.xul are using an out-of-date API.
You may find more details about this deprecation at: https://developer.mozilla.org/en-US/Add-ons/Code_snippets/View_Source_for_XUL_Applications


Expected results:

It should have opened without error messages - also although this is not breaking anything yet, could this be a good time to fix it...?
Yes, I've seen this before and yes, we should fix this.

Looks like we need to replace the call at:
https://dxr.mozilla.org/comm-central/rev/058aa6495c2db7c13eac1e23c74d2354bf9d6355/mail/base/content/mailCommands.js#511
https://developer.mozilla.org/en-US/Add-ons/Code_snippets/View_Source_for_XUL_Applications has some information.

Richard, care to take a look?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(richard.marti)
Component: Untriaged → General
Strange, when I use the view source of a message I only get:

ReferenceError: reference to undefined property "shouldWrap"[Learn More]  viewSource-content.js:111:1

But from Error console I get the error of comment 0 too. It seems the DevTools use an other way to show the console. In FX set to show the source in a window, it shows the "shouldWrap" error too.
Flags: needinfo?(richard.marti)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163707
You need to log in before you can comment on or make changes to this bug.