Opening many Tabs dosn't work properly

VERIFIED DUPLICATE of bug 106927

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 106927
16 years ago
10 years ago

People

(Reporter: Dominik Stadler, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Normally when more tabs are opened, the tab-title gets smaller and smaller in
order to display all tabs. 

Now if I open many tabs (more than 30 on my 19" monitor), some minimal size of
the tab-titles is reached and mozilla tries to display them outside of the
border of the mozilla-window. 

The effect of this is that also the scrollbar for the browsing window and the
small "x" for closing tabs is not visible any more and also contents of browsing
windows is rendered bigger than the screen is.

Reproducible: Always
Steps to Reproduce:
1. Open any web-page that has some text on it, for example this page
http://www.mozilla.org/quality/help/bugzilla-helper.html
2. Click on a link with CTRL-T to open it in additional Tabs multiple times
(around 35 times on my monitor)


Actual Results:  When the Tab-Title is not rendered smaller anymore when opening
new tabs, the scrollbar on the right side of the browsing window is not visible
any more and also text on the web-page is rendered with bigger window-size than
visible.

Expected Results:  There are multiple options for this:
1. multiple tab-rows are introduced if the tabs don't fit on one row.
2. or some way of scrolling the tab-titles horizontally is introduced.
3. or new tabs are simply not displayed any more until existing tabs are closed.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 106927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.