Closed Bug 1427826 Opened 2 years ago Closed 2 years ago

Crash in nsDisplayListBuilder::IsAnimatedGeometryRoot

Categories

(Core :: Web Painting, defect, P1, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1427221
Tracking Status
firefox59 --- affected

People

(Reporter: marcia, Assigned: mattwoodrow)

References

()

Details

(Keywords: crash, reproducible)

Crash Data

This bug was filed from the Socorro interface and is
report bp-02617e0d-2b3a-489c-9da3-1133f0171231.
=============================================================

Seen while looking at Mac nightly crash data: http://bit.ly/2AkEV9S. Crashes happening on 10.11 - 10.13. I can reproduce this on my machine using http://docs.gl/gl4/glClearColor

Top 10 frames of crashing thread:

0 XUL nsDisplayListBuilder::IsAnimatedGeometryRoot layout/generic/nsIFrame.h:2797
1 XUL nsDisplayListBuilder::FindAnimatedGeometryRootFor layout/painting/nsDisplayList.cpp:1832
2 XUL RetainedDisplayListBuilder::ComputeRebuildRegion layout/painting/RetainedDisplayListBuilder.cpp:608
3 XUL RetainedDisplayListBuilder::AttemptPartialUpdate layout/painting/RetainedDisplayListBuilder.cpp:828
4 XUL nsLayoutUtils::PaintFrame layout/base/nsLayoutUtils.cpp:3808
5 XUL mozilla::PresShell::Paint layout/base/PresShell.cpp:6495
6 XUL nsViewManager::ProcessPendingUpdatesPaint view/nsViewManager.cpp:480
7 XUL nsViewManager::ProcessPendingUpdatesForView view/nsViewManager.cpp:412
8 XUL nsViewManager::ProcessPendingUpdates view/nsViewManager.cpp:1102
9 XUL nsRefreshDriver::Tick layout/base/nsRefreshDriver.cpp:2046

=============================================================
Assignee: nobody → matt.woodrow
Blocks: 1352499
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1427221
You need to log in before you can comment on or make changes to this bug.