Thunderbird Daily becomes unresponsive when Add-ons Manager opened from hamburger after bug 1427407 landed

VERIFIED FIXED in Thunderbird 60.0

Status

defect
--
blocker
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: walts48, Assigned: aceman)

Tracking

({perf, regression})

Thunderbird 60.0
All
Windows 10
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird59 fixed, thunderbird60 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

a year ago
Open Thunderbird Daily 59.0a1
Activate the Menu Button
Select Add-ons and allow the extensions with preferences sub-menu to appear
Open the Add-ons Manager tab

Try to close the tab and TB Daily doesn't respond
I can't select or close any other tabs
I need to use End task in Windows Task Manager to close Thunderbird

The problem does not occur if I don't allow the sub-menu to appear 
The problem does not occur with TB Daily on Linux
Blocks: 1427407
Keywords: perf, regression

Comment 1

a year ago
Fortunately I can't reproduce this, Richard, can you?
Flags: needinfo?(richard.marti)
No, no such issue here. Walt, have you tried with all Add-ons disabled?
Flags: needinfo?(richard.marti)
Reporter

Comment 3

a year ago
I just tried with a test profile, Lightning disabled on startup
Using the Menu Button > Add-ons and allowing the sub-menu to appear, showed that there are "No add-on settings found"
Activating Add-ons from the sub-menu, the tab doesn't complete loading, throbber keeps spinning, and TB is still unresponsive

Starting my production profile in Safe Mode, allowing the sub-menu to appear, activating Add-ons, the tab loads and TB becomes unresponsive.

I'm using BuildID: 20180103030201, but this did appear for me with the first build after bug 1427407 landed. Just didn't have time to file the report until now.
Reporter

Comment 4

a year ago
Just tested the 32-bit Windows build in my Test user account with the same results.

The sub-menu must be showing before the user activates Add-ons to open the Add-ons Manager
Reporter

Comment 5

a year ago
First appeared using Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Thunderbird/59.0a1
BuildID: 20171231030201
Assignee

Comment 6

a year ago
I can't see this either. Whether there is "No add-on settings found" or there are preferences for some addons.
And also whether I click the "add-ons" in the main menu or the one in the submenu.
Reporter

Comment 7

a year ago
Well, I'm unique.

Uninstalled Daily from Windows 10. It was installed in C:\Users\WaltS48\AppData\Local\Daily. Custom installation on my part I guess.
Downloaded and installed BuildID: 20171231030201 into the standard location C:\Program Files\Thunderbird Daily.
Launched it with new test profile.
Using the Menu Button > Add-ons and allowing the sub-menu to appear, showed that there are "No add-on settings found".
Activating Add-ons from the sub-menu menu item, the tab doesn't complete loading, throbber keeps spinning, and TB is still unresponsive.
Allowed Daily to update to BuildID: 20180103030201 and restarted.
Quickly activated the Add-ons menu item from the Menu Button, enabled Lightning and restarted.
Allowed the Add-ons sub-menu to appear and selected Add-ons, tab doesn't completely load and TB is unresponsive.

Used Windows Task Manager to End Process.

Any suggestions as to what else I should try? Short of reinstalling Windows10.
Reporter

Comment 8

a year ago
Well, I'll try to remember to use the Menu bar, Tools > Add-ons to open the Add-ons Manager, or be quicker in using the Menu button, since nobody can reproduce this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Assignee

Comment 9

a year ago
You say this happens also with all addons disabled and only when using the hamburger menu on the Addons item, waiting for the submenu and clicking Addons there? NOT with the menu bar -> Addons nor in hamburger button (appmenu) when quickly clicking Addons?
Reporter

Comment 10

a year ago
(In reply to :aceman from comment #9)
> You say this happens also with all addons disabled and only when using the
> hamburger menu on the Addons item, waiting for the submenu and clicking
> Addons there? NOT with the menu bar -> Addons nor in hamburger button
> (appmenu) when quickly clicking Addons?

That is correct.

Add-ons disabled or with a new profile, no accounts created, bundled Lightning not enabled.

Comment 11

a year ago
For me it hangs (spinner) when I do this:
Hamburger button (Open Menu) -> Add-ons -> Add-ons

You cannot click on anything, even window close does not work.
You have to use the task manager to kill the process.

If you get to the window through:
ALt (to get the menu bar)-> Tools -> Add-ons
Then it work fine.

Using Daily build: 60.0a1 (2018-02-05) (64bit)
Windows 10 (tried multiple version).
Reporter

Comment 12

a year ago
Reopening based on Comment 11.
Status: RESOLVED → UNCONFIRMED
Hardware: x86_64 → All
Resolution: INVALID → ---

Comment 13

a year ago
I can confirm this bug on Windows 10 64Bit with Daily 60.0a1. This is Happening on clean/fresh profiles. I can access AddOn Manager fine via Menu -> Tools -> Add-On, but not via the Hamburger button.

Restarting with all addons disabled and resetting everything does not help.

Also, I found this strange behaviour: Starting with a fresh Profile and doing nothing, just pressing CTRL+SHIFT+J to open the console, I get this JS Error:

No chrome package registered for chrome://browser/content/built_in_addons.json
1517992708659	addons.xpi	WARN	List of valid built-in add-ons could not be parsed.: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: _readAddons :: line 6381"  data: no] Stack trace: _readAddons()@resource://gre/modules/addons/XPIProvider.jsm:6381 < getAddonLocations()@resource://gre/modules/addons/XPIProvider.jsm:6042 < getInstallState()@resource://gre/modules/addons/XPIProvider.jsm:1587 < checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3201 < startup()@resource://gre/modules/addons/XPIProvider.jsm:2181 < callProvider()@resource://gre/modules/AddonManager.jsm:258 < _startProvider()@resource://gre/modules/AddonManager.jsm:733 < startup()@resource://gre/modules/AddonManager.jsm:897 < startup()@resource://gre/modules/AddonManager.jsm:2972 < observe()@jar:file:///C:/Program%20Files/Thunderbird%20Daily/omni.ja!/components/addonManager.js:65

I can restart TB once and still get this Error. After the second restart, no more. Maybe it is related.

Comment 14

a year ago
(In reply to john.bieling from comment #13)
> I get this JS Error:
> 
> No chrome package registered for
> chrome://browser/content/built_in_addons.json
> etc.
That can be safely ignored, but we're fixing this in bug 1416480.

Comment 15

a year ago
Hey, I can reproduce this on one of my profiles!

As described in comment #0:
- Activate the Menu Button (Hamburger button)
- Select "Add-ons" and allow the extensions with preferences sub-menu to appear
- Click on "Add-ons", not anything in the sub-menu, to open the Add-ons Manager tab

TB is now hung, can't switch tabs, can't close. Every click on a tab results in a "bing" as if there were a modal panel you'd have to dismiss first :-(
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(acelists)
Assignee

Comment 16

a year ago
Ok, first theory. The code of the submenu starts like this:
<menupopup id="appmenu_addonPrefs"
           onpopupshowing="initAddonPrefsMenu(this);"
           oncommand="openAddonPrefs(event.target.value, event.target.getAttribute('optionsType'));">
  <menuitem label="&addons.label;" oncommand="openAddonsMgr();"/>

Jorg, can you check whether when clicking the "Add-ons" item (&addons.label;) the openAddonsMgr() executes, but also the openAddonPrefs() command?
Flags: needinfo?(acelists)

Comment 17

a year ago
I added dumps in openAddonPrefs() and openAddonsMgr() and when I repeat the steps I see:
=== openAddonsMgr
=== openAddonPrefs
So yes, both run and we're hosed :-( Not so bad in a debug build since I can close the debug console ;-)

Anyway, that should be very easy to fix and we can ship it out in TB 59 beta which has been delayed anyway.
Assignee

Comment 18

a year ago
Thanks.
Yes, there is some way to prevent the event bubbling up and firing also the command of the parent.
I'll take this.
Reporter

Comment 19

a year ago
(In reply to :aceman from comment #18)
> Thanks.
> Yes, there is some way to prevent the event bubbling up and firing also the
> command of the parent.
> I'll take this.

Maybe separate the commands like I suggest in bug 1427407, so it matches what is under Tools?

One for Add-ons and one for Add-ons Options.
Assignee

Comment 20

a year ago
Posted patch 1428082.patchSplinter Review
Can you try this?
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #8949079 - Flags: review?(jorgk)

Comment 21

a year ago
I do not know how to build TB from source, but I will test any new Daily Version.

Comment 22

a year ago
Comment on attachment 8949079 [details] [diff] [review]
1428082.patch

(In reply to Jorg K (GMT+1) from comment #15)
> - Click on "Add-ons", not anything in the sub-menu, to open the Add-ons
>   Manager tab
Sigh, this last step was wrong.

The problem occurs when you select the add-ons manager *from* the sub-menu. Since this happens on the right screen edge, the popup folds over the original menu, so I got confused where I clicked :-(

In any case, the patch works. Aceman, is this not a problem on Linux?
Attachment #8949079 - Flags: review?(jorgk) → review+

Comment 23

a year ago
(In reply to john.bieling from comment #21)
> I do not know how to build TB from source, but I will test any new Daily
> Version.
It will be fixed tomorrow (assuming that tomorrow's Daily won't be busted).
Assignee

Comment 24

a year ago
(In reply to Jorg K (GMT+1) from comment #22)
> In any case, the patch works. Aceman, is this not a problem on Linux?

The execution of both functions happens on Linux too, but it seems to not have the effect of freezing TB.
Assignee

Comment 25

a year ago
Thanks for checking.

Thanks for noticing this Walt!
Keywords: checkin-needed

Comment 26

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a0716b4dadb5
do not bubble up command execution in appmenu_addonPrefs popup. r=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: a year agoa year ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

a year ago
Target Milestone: --- → Thunderbird 60.0

Updated

a year ago
Attachment #8949079 - Flags: approval-comm-beta+

Comment 27

a year ago
Fixed for me in Daily 2018-02-08!
This is a release blocker
(just to be clear)
Severity: major → blocker
Summary: Thunderbird Daily becomes unresponsive when Add-ons Manager opens after bug 1427407 landed → Thunderbird Daily becomes unresponsive when Add-ons Manager opened from hamburger after bug 1427407 landed
Verified fixed on the uplift to TB 59.0b1 (build2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.