[PP]linux only-AutoComplete works only with the first recipient field

VERIFIED WORKSFORME

Status

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

AC works only with the first recipient field because it's the only one to have an id (msgRecipient#1). Others
recipient fields created dynamically don't have an id therefore AC faild.
There is no way to create an id on a node dynamically added to the DOM.  This is

why the JS code for the dynamic addressing widget has routines to get these DOM

elements.  You will need to use these routines or routines like them to access

these elements.
Assignee: hangas → ducarroz
Sending back to JF, this lack of ID is not a bug - it is a feature :-)
Status: NEW → ASSIGNED
Target Milestone: M11
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed and checked in
QA Contact: lchiang → esther
Status: RESOLVED → REOPENED
OS: Mac System 8.5 → Linux
Hardware: Macintosh → HP
Summary: AutoComplete works only with the first recipient field → [PP]linux only-AutoComplete works only with the first recipient field
Resolution: FIXED → ---
Using 19990928 build on win98 and mac this works now,  however linux does not.
Changing this to platform parity [PP] for linux and reopening.
Seth, could you take a look at it for me? Thanks.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Linux (1999-10-13-08 M11)
This problem has been fixed. Autocomplete works for first and second receipient.
Mark it worksforme.
Status: RESOLVED → VERIFIED
Based on Fenella's comment on 10/14 marking verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.