Closed Bug 1428187 Opened 2 years ago Closed 2 years ago

Crash in InvalidArrayIndex_CRASH | nsTArray_Impl<T>::ElementAt | mozilla::detail::RunnableFunction<T>::Run

Categories

(Core :: Audio/Video: Playback, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1428184
Tracking Status
firefox59 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-5e5834e8-c13a-4d90-bfda-8f7520180104.
=============================================================

Seen while looking at nightly crash stats - crashes started using 20180103230310. Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4d1423f75c677447cafb8cd3f9a5fbdff8bfbca8&tochange=c9bec96cc78978b5282185534d7e7c8c436e7822

Bug 1427666 is in the range, ni on jwwang

One comment says: "was watching videos in private tabs, closed all tabs at once and crashed "

Top 10 frames of crashing thread:

0 libmozglue.so MOZ_CrashPrintf mfbt/Assertions.cpp:63
1 libxul.so InvalidArrayIndex_CRASH xpcom/ds/nsTArray.cpp:26
2 libxul.so nsTArray_Impl<BloatEntry*, nsTArrayInfallibleAllocator>::ElementAt 
3 libxul.so mozilla::detail::RunnableFunction<>::Run xpcom/ds/ArrayIterator.h:86
4 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1040
5 libxul.so NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:510
6 libxul.so mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:364
7 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:326
8 libxul.so nsThread::ThreadFunc xpcom/threads/nsThread.cpp:423
9 libnss3.so _pt_root nsprpub/pr/src/pthreads/ptthread.c:201

=============================================================
Flags: needinfo?(jwwang)
Duping to the bug Andrew filed.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jwwang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1428184
You need to log in before you can comment on or make changes to this bug.