Email subject and To/From mismatch with email contents shown in preview with IMAP

RESOLVED DUPLICATE of bug 1430480

Status

defect
RESOLVED DUPLICATE of bug 1430480
2 years ago
2 years ago

People

(Reporter: ziomau10, Unassigned)

Tracking

(Blocks 1 bug)

52 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171024165158

Steps to reproduce:

Happens very frequently moving mails between IMAP folders belonging to different accounts and thus different servers.
I've found no step sequence to surely reproduce.
Happens more frequently with large mailboxes.


Actual results:

Selecting some message in the message list shows different message contents in the preview pane.
Subject and senders are correct, but the contents are not.
Usually they show some previous message on the same folder.
I know that this can be fixed with a "Folder Repair", and I usually do that.
The point is that I experience this problem every other day or more, and I think this reveals some subtle bug, maybe worth investigating.


Expected results:

Prevew pane showing the contents matching the message selected
Sadly there are a few reports of this kind, see meta-bug 714489.
We've just go another report on this and I actually have a reproducible case that corrupts my mailbox reliably. So let's do a forward dupe here.

> Usually they show some previous message on the same folder.
Indeed, that's what I see.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1430480
You need to log in before you can comment on or make changes to this bug.