Closed Bug 1428282 Opened 2 years ago Closed 2 years ago

Email Archive right click ineffective

Categories

(SeaMonkey :: MailNews: General, defect)

SeaMonkey 2.52 Branch
defect
Not set

Tracking

(seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.58 wontfix, seamonkey2.59 fixed)

RESOLVED FIXED
seamonkey2.59
Tracking Status
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.58 --- wontfix
seamonkey2.59 --- fixed

People

(Reporter: domfillon, Assigned: frg)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0 SeaMonkey/2.56a1
Build ID: 20171210042420

Steps to reproduce:

Main account Email is O365.
Right click on one Email or a goup of Emails, select Archive


Actual results:

Nothing


Expected results:

Emails should have been moved to the appropriate Archive folder (Archiving is selected to be on year / month folder structure).
Problem shown on SM 2.56, tested in safe mode and normal mode.
Problem tested showing in build 20171210 up to 20180102. I could not test earlier version yet.
Component: General → MailNews: General
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Error console msg: 

Timestamp: 1/5/2018, 10:05:10 AM
Error: TypeError: msgDate.toLocaleFormat is not a function
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1132
Assignee: nobody → frgrahl
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
See Also: → 1356272
Version: SeaMonkey 2.56 Branch → SeaMonkey 2.52 Branch
Need to test if this is all which is needed before asking for review.
OS: Windows 10 → All
Hardware: x86_64 → All
Dominique,

could you probably try the 2.53 build from here and let me know if the problem is fixed:

http://www.wg9s.com/comm-253/

I haven't set up email archiving yet and are a little short on time with all the bugs popping up. If you are running an earlier SeaMonkey version and want to go back to it please backup your profile.  The 2.53 version has extensive changes in preparation for the next 2.57 release in it.
Flags: needinfo?(dominique.fillon)
Hell Frank-Rainer,

Yes, this problem is now gone in 2.53 from Bill !
Bugzilla never forgets anything, although I forgot submitting this one !!
Can be closed a fixed (??) or works for me.
Flags: needinfo?(dominique.fillon)
> Can be closed a fixed (??) or works for me.

Better not. This release was done from private tree. Needs to go into the official one :)
Attachment #8941806 - Flags: review?(iann_bugzilla)
Comment on attachment 8941806 [details] [diff] [review]
1428282-msgArchiveDate.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 818634
User impact if declined: error when archiving email
Testing completed (on m-c, etc.): c-r 2.53 and verified by reporter
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: --
Attachment #8941806 - Flags: approval-comm-esr60?
Original api was removed for Fx 58 (2.55). Locale api changes might have caused problems since 2.52. Didn't test.
Do we need to fix the following too?
https://dxr.mozilla.org/comm-central/source/suite/common/sync/syncUI.js#292
Flags: needinfo?(frgrahl)
Comment on attachment 8941806 [details] [diff] [review]
1428282-msgArchiveDate.patch

LGTM a/r=me
Attachment #8941806 - Flags: review?(iann_bugzilla)
Attachment #8941806 - Flags: review+
Attachment #8941806 - Flags: approval-comm-esr60?
Attachment #8941806 - Flags: approval-comm-esr60+
Oh didn't see this. In theory yes. Practically all sync code is currently disabled since bug 1432273 and needs a major rewrite. Followup bug or put it in the user story of bug 998807.
Flags: needinfo?(frgrahl)
(In reply to Frank-Rainer Grahl (:frg) from comment #11)
> Oh didn't see this. In theory yes. Practically all sync code is currently
> disabled since bug 1432273 and needs a major rewrite. Followup bug or put it
> in the user story of bug 998807.

If it is definitely disabled at the moment, then yes put in the user story, otherwise follow-up bug.
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/fa0006f8bdc1
Replace obsolete toLocaleFormat for SeaMonkey archive folder name generation. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/comm-esr60/rev/9797b9e8b49b

Sync is completely disabled in current releases > 2.49. The private 2.53 patch tree also includes the disable patch. Will update the user-story.
Target Milestone: --- → Seamonkey2.59
You need to log in before you can comment on or make changes to this bug.