Closed Bug 1428289 Opened 2 years ago Closed 2 years ago

Release mozversion 1.5

Categories

(Testing :: Mozbase, defect)

Version 3
defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(1 file)

Some of the latest mozlog changes seem to have broken mozversion:

$ virtualenv venv
$ . venv/bin/activate
(venvtest) $ pip install mozversion
Collecting mozversion
Collecting mozfile>=1.0 (from mozversion)
Collecting mozlog>=3.0 (from mozversion)
  Downloading mozlog-3.6-py2-none-any.whl (58kB)
    100% |################################| 61kB 730kB/s
Collecting blessings>=1.3 (from mozlog>=3.0->mozversion)
  Downloading blessings-1.6.1-py2-none-any.whl
Installing collected packages: mozfile, blessings, mozlog, mozversion
Successfully installed blessings-1.6.1 mozfile-1.2 mozlog-3.6 mozversion-1.4
(venvtest) $ mozversion /Applications/FirefoxNightly.app
Traceback (most recent call last):
  File "/usr/local/bin/mozversion", line 9, in <module>
    load_entry_point('mozversion', 'console_scripts', 'mozversion')()
  File "/usr/local/lib/python2.7/site-packages/mozversion/mozversion.py", line 319, in cli
    structured.commandline.add_logging_group(
NameError: global name 'structured' is not defined

Andrew, given that you did a bit of work in that area, can you please check? This regression blocks me because it also affects consumers like marionette client. Thanks
Flags: needinfo?(ahalberstadt)
Wow, this was fixed already 2 years ago via bug 1218373, but we never released a new version to PyPI. Lets get a new release out!
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Depends on: 1218373
Flags: needinfo?(ahalberstadt)
Summary: [mozversion] NameError: global name 'structured' is not defined → Release mozversion 1.5
Attachment #8940110 - Flags: review?(jmaher)
Comment on attachment 8940110 [details]
Bug 1428289 - Release mozversion 1.5.

https://reviewboard.mozilla.org/r/210394/#review216134
Attachment #8940110 - Flags: review?(jmaher) → review+
Attachment #8940110 - Flags: review?(ato)
https://hg.mozilla.org/mozilla-central/rev/6f651c2c5b21
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
I still have to release the bits to PyPI. Will do it later today.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Uploading distributions to https://upload.pypi.org/legacy/
Uploading mozversion-1.5-py2-none-any.whl
Uploading mozversion-1.5.tar.gz
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.