Closed Bug 1428292 Opened 2 years ago Closed 2 years ago

On canadiantire.ca the autofill doesn't work on the billing form

Categories

(Toolkit :: Form Autofill, defect)

59 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox59 --- verified

People

(Reporter: Ovidiu, Assigned: selee)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:V2][Misc.])

Attachments

(1 file)

Affected versions]:

Tested on Nightly 59.0a1(2018-01-04)

[Affected platforms]:

Tested on Mac OS X 10.12, Windows 10

[Steps to reproduce]:

Prerequisites:
 1. Make sure you have at least two saved profile.
 
 STR:

1. Go to https://www.canadiantire.ca and buy an item
2. In the billing form double click on "First Name" or "Last Name"


[Expected result]:

The autofill suggestions are displayed. 

[Actual result]:

Nothing happens. 

NOTE: Here is a video of the actual result: https://streamable.com/uha48 
We checked after autocomplete=off but we didn't see this attribute for "First name" or "Last name".
Whiteboard: [form autofill: V2]
I'll look into it soon.
Assignee: nobody → lchang
Whiteboard: [form autofill: V2] → [form autofill:V2][Misc.]
I just looked into it and it seems the heuristic problem that first name/ last name/address line 2/ city/ postal code/ tel fields will be detected as tel-extension, only address level 1 (province)/ country/ email/ tel-extension fields are correct. This also causes the unnecessary sectioning because of duplicate tel-extension fields, so the rest of the correct fields could not be filled because there's no sufficient valid fields in a section.
Flags: needinfo?(lchang)
This issue is caused by missing detection tel-extension by its regexp rule (`"\\bext|ext\\b|extension"`), and Bug 1392932 is a similar one.

I submit a WIP patch to determine tel-extension from the regexp list to telephone parser only, and there are some test fails have to be resolved.
Assignee: lchang → selee
Status: NEW → ASSIGNED
Flags: needinfo?(lchang)
See Also: → 1392932
Duplicate of this bug: 1392932
This patch is based on the solution I purposed in comment 4, and it fixed the issue in bug 1392932. In addition, this patch will be rebased on bug 1417834 later since bug 1417834 is not landed yet.
Comment on attachment 8940628 [details]
Bug 1428292 - Determine tel-extension in telephone parser only.

https://reviewboard.mozilla.org/r/210860/#review218076

Looks good.
Attachment #8940628 - Flags: review?(lchang) → review+
Thanks for the review. The patch is rebased to the latest m-c.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/860a997f95c9
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Hi Ovidiu, can you help us to verify these bug? Thanks.
Flags: needinfo?(ovidiu.boca)
I verified this on Mac OS X 10.12, Windows 10 x64 and Ubuntu 16.04 with Nightly 59.0a1(2018-01-14) and I can confirm the fix, I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(ovidiu.boca)
You need to log in before you can comment on or make changes to this bug.