Closed Bug 1428294 Opened 4 years ago Closed 4 years ago

Broken layout of multi-line console log messages when containing objects

Categories

(DevTools :: Console, defect)

57 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1403977

People

(Reporter: mail, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171227151400

Steps to reproduce:

1. Open the Developer Tools console.
2. Type "console.log('%o\nfoo', {})" and press enter.



Actual results:

The "foo" text gets moved down a line, but not to the beginning of the line. Note that the bounding box of the collapsed object in the screenshot is higher than usual. This happens in Firefox 57.


Expected results:

The "foo" text should get displayed to the beginning of the next line. This happened in Firefox 56 and earlier.
Component: Untriaged → Developer Tools: Console
Hello Mads, thanks for filing an issue !
I think this is now fixed in Firefox 59 (Nightly, soon in DevEdition) by Bug 1403977.

Thus I'm marking this bug as a duplicate and closing it.
If you think that's not the same issue, or that the issue is not fixed on nightly, feel free to reopen this bug and explain why it is not working for you.

Thanks !
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1403977
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.