Closed Bug 1428356 Opened 4 years ago Closed 4 years ago

Top Sites are wrongly reordered while a Top Site is dismissed, if empty Top Sites exist between them

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 59
Iteration:
59.4 - Jan 15
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- verified
firefox60 --- verified

People

(Reporter: cmuresan, Assigned: rrosario)

References

Details

Attachments

(2 files)

[Affected versions]:
- Firefox 59.0a1 Build ID 20180104220114

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a clean new profile.
- Top Sites are ordered in such a way that the first position is empty, empty spaces exist between Top Sites and there is one Top Site in the last position.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites and open a new tab.
2. Dismiss the 2nd Top Site and observe the behavior.
 
[Expected results]:
- The Top Site is dismissed.

[Actual results]:
- All Top Sites are reordered so that no spaces exist between them, then moved back to their original positions and the Top Site is dismissed.

[Notes]:
- Attached a screen recording of the issue.
Assignee: nobody → rrosario
Iteration: --- → 1.26
Priority: -- → P1
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/71a141c5c40893501b95a7c203d0ed3f70b6f1a2
Fix Bug 1428356 - dismissing/deleting Top Sites when some are pinned

https://github.com/mozilla/activity-stream/commit/406b094ead23fb132578e78820a08d4231282186
Merge pull request #3925 from rlr/bug1428356/dismiss-and-pinned

Fix Bug 1428356 - dismissing/deleting Top Sites when some are pinned
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: 1429530
Iteration: 1.26 → 59.4 - Jan 15
See Also: → 1430130
Flags: qe-verify+
QA Contact: iulia.cristescu
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Firefox: 60.0a1, Build ID 20180126035135

I have verified that this issue is no longer reproducible on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12 with the latest Nightly build (60.0a1) installed. Now the "Top Sites" are not reordered while a Top Site is dismissed.
Status: RESOLVED → VERIFIED
Updating the bug status and the tracking flags to reflect the current situation, based on the above comment.
Status: VERIFIED → RESOLVED
Closed: 4 years ago4 years ago
I've also managed to reproduce this issue on Firefox 59.0a1 (2018-01-05), under Windows 10x64.
The issue is no longer reproducible on Firefox 59.0b5. Tests were performed under Windows 10x64, Ubuntu 16.04x64 and under macOS 10.12.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.