Closed Bug 1428397 Opened 2 years ago Closed 2 years ago

Switch neti.ee searchplugin to https

Categories

(Mozilla Localizations :: et / Estonian, enhancement)

enhancement
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: flod, Assigned: flod)

Details

Attachments

(2 files)

https://hg.mozilla.org/mozilla-central/file/tip/browser/locales/searchplugins/neti-ee.xml

Looks like there's an https version available, but the main problem is that any search on the website fails with

You don't have permission to access /cgi-bin/otsing on this server.

e.g. http://www.neti.ee/cgi-bin/otsing?query=test&src=web

@Merike or Sander
Do you have any information about this search engine? Should we try to get in touch or just drop it?
Hey!

Where or how did You test it? It seems to work for me. HTTP and HTTPS are both working here.
Did some more testing, it seems that they expect a reasonable User-Agent string.

This for me works:

curl -A "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0" http://www.neti.ee/cgi-bin/otsing?query=test
(In reply to sander.lepik from comment #1)
> Hey!
> 
> Where or how did You test it? It seems to work for me. HTTP and HTTPS are
> both working here.

Interesting, it was broken for at least 15 minutes (both direct URL above, or searching from the homepage). Now it works.

I guess they had some temporary issues. 

At this point we can use this bug to switch to https, will wait a couple of days to see if it happens again.
Assignee: nobody → francesco.lodolo
Summary: Neti.ee searchplugin is broken → Switch neti.ee searchplugin to https
Attached file neti-ee.xml
I have an updated version (new icon 16+32px, https).

The problem is that I still get more 403 than result pages, and I have no clue what's going on. 

I can open a page and get results, open a new private window with the same URL and it fails. I go back to the existing tab, reload, and it reloads fine. It's not just the searchplugin, it happens also when searching from the website.
10/10 fail for me via curl
https://gist.github.com/flodolo/a718adb6b98d9e2465fa980479cc4b23

Sometimes the same URL loads in the browser, most of the time it doesn't.
You aren't saying it fails only for https though?

I suspect they're doing some sort of rate limiting or other filtering for foreign addresses. I get 10/10 success when trying from local ip, and about 4/10 when trying from a DigitalOcean droplet in Amsterdam. Without explicitly asking them it's hard to tell what they're doing but it shouldn't cause any more issues on https than on http..
(In reply to Merike Sell (:merike) from comment #6)
> You aren't saying it fails only for https though?

No, I have the same behavior on http and https

> Without explicitly asking them it's hard to tell

Could you or Sander try to get in touch to confirm that's expected behavior?
Per email discussion: they're aggressively filtering IPs outside of Estonia, that affects testing but not users in the country.

For that reason, I think it makes sense to keep the searchplugin in, and update it.
Comment on attachment 8943615 [details]
Bug 1428397 - [et] Switch neti.ee searchplugin to https, update icon

https://reviewboard.mozilla.org/r/213994/#review219820
Attachment #8943615 - Flags: review?(mozilla) → review+
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/6b413c2c9bfe
[et] Switch neti.ee searchplugin to https, update icon r=mkaply
https://hg.mozilla.org/mozilla-central/rev/6b413c2c9bfe
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.