Editor's horizontal scrollbar in Response panels does not appear until scroll to bottom

RESOLVED FIXED in Firefox 59

Status

defect
P2
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: rickychien, Assigned: rickychien)

Tracking

Trunk
Firefox 59
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(4 attachments)

Comment 2

a year ago
mozreview-review
Comment on attachment 8940402 [details]
Bug 1428521 - Draw editor's horizontal scrollbar in Response panels

https://reviewboard.mozilla.org/r/210674/#review216510

thanks for address this
Attachment #8940402 - Flags: review?(gasolin) → review+

Comment 3

a year ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c28c6de838a2
Draw editor's horizontal scrollbar in Response panels r=gasolin
Devtools failures on this push https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=c28c6de838a2ada725e1b45c9d66bcce2b1b65d8 

@Ricky Chien can you please take a look?
Flags: needinfo?(rchien)
Backed out for failing devtools/client/netmonitor/test/browser_net_post-data-01.js

backout: https://hg.mozilla.org/integration/autoland/rev/faf89839e08023c7f66dba5140cd15b75e1e23bb

push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=c28c6de838a2ada725e1b45c9d66bcce2b1b65d8

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=154667464&repo=autoland&lineNumber=11411

20:11:12     INFO - TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_post-data-01.js | The text shown in the source editor is incorrect (4.1). - 
11412
20:11:12     INFO - Stack trace:
11413
20:11:12     INFO -     chrome://mochitests/content/browser/devtools/client/netmonitor/test/browser_net_post-data-01.js:testParamsTab:150
11414
20:11:12     INFO -     process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:922:23
11415
20:11:12     INFO -     walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:806:7
11416
20:11:12     INFO -     Promise*scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:739:11
11417
20:11:12     INFO -     schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:770:7
11418
20:11:12     INFO -     completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:707:7
11419
20:11:12     INFO -     receiveMessage@resource://testing-common/ContentTask.jsm:113:9
11420
20:11:12     INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net_post-data-01.js | The text shown in the source editor is incorrect (2.2). - 
11421
20:11:12     INFO - TEST-PASS | devtools/client/netmonitor/test/browser_net_post-data-01.js | The text shown in the source editor is incorrect (3.2). - 
11422
20:11:12     INFO - Not taking screenshot here: see the one that was previously logged
11423
20:11:12     INFO - TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_post-data-01.js | The text shown in the source editor is incorrect (4.2). -
Thanks, solution has been found.
Flags: needinfo?(rchien)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 11

a year ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c5c1fe6738f8
Draw editor's horizontal scrollbar in Response panels r=gasolin

Comment 12

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c5c1fe6738f8
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59

Comment 13

a year ago
I have verified this bug fix in the latest Nightly build (20180109100117). However, scrollbars corner overlap after switch Toolbox tab. Please find the attached video.

I think it is similar issue with below.
https://github.com/devtools-html/debugger.html/issues/5022
Flags: needinfo?(rchien)
Hmm... that's odd. I cannot reproduce this issue on my macOS (10.13.2) machine. Even I swtich "Show scroll bars" to always on System preferences, it doens't show the overlap like your video.

@magicp, could you help me verify are other platforms having this issue? thanks
Flags: needinfo?(rchien)

Comment 15

a year ago
(In reply to Ricky Chien [:rickychien] from comment #14)
> @magicp, could you help me verify are other platforms having this issue?
> thanks

It only reproduce on Windows as cannot reproduce on macOS and Ubuntu.
OK, cool thanks! I suspect it could be a Windows only issue...

Comment 17

a year ago
Posted image macOS-10.13.2.png
I was able to reproduce on macOS.

Comment 18

a year ago
Posted image ubuntu-16.04.png
I was able to reproduce on Ubuntu 16.04

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.