Closed Bug 1428579 Opened 2 years ago Closed 2 years ago

TaskCluster 'Sign-In with Email' button seems load a blank page

Categories

(Taskcluster :: Services, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jfrench, Assigned: dustin)

Details

Attachments

(1 file)

The TaskCluster 'Sign-In with Email' button seems load a blank page.

Here's steps to reproduce:

o load https://login.taskcluster.net/
o click on the 2nd blue button 'Sign-In with Email'

Observed:
o the loaded page (https://login.taskcluster.net/auth0/login-local) is blank

As a non-employee I used to use this particular workflow, although I discovered I can use the first button and log in with Auth0 and send myself a valid login credential. This allowed me to log in to Treeherder fine, which was where I discovered this issue.
Attached image signInWithEmail
Per screen grab, using this button.
Ah, looks like it's a CSP issue -- easy enough to fix.  But yes, Auth0 is the right way to login now (for everyone).
Assignee: nobody → dustin
I haven't gotten back to this in a bit.  But at this point, with linked accounts, that sign-in-with-email button doesn't work for anyone anymore.  And Treeherder will be using a completely different signin process very soon (bug 1395356), so this will all go away.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
How about just removing/commenting out the sign-in-with-email button so we don't keep clicking on it (assuming that TC page is going to stick around) even after Treeherder switches to something else?
The page is going to go away (in theory in October 2017, and in practice the patch is nearing r+), but yes, I can remove the button.
Cool, thanks! :)
Component: Login → Services
You need to log in before you can comment on or make changes to this bug.