Closed Bug 1428634 Opened 5 years ago Closed 5 years ago

(Composer) Insert Link doesn't work

Categories

(SeaMonkey :: Composer, defect)

SeaMonkey 2.49 Branch
Unspecified
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1417819

People

(Reporter: NeuMoPho, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.1
Build ID: 20171016003553

Steps to reproduce:

Using Composer with some text selected, I Insert->Link and press "Choose File..." and select an HTML document and press "Open" and nothing happens. 

This does work after creating a new Composer document, but not after opening and editing a saved HTML document.


Actual results:

It doesn't fill out the Link Location and does not enable the "OK" button. I was sad.


Expected results:

The Link Location should have been filled out and the "OK" button should have been enabled. I should have been happy.
(In reply to NeuMoPho from comment #0)

Unfortunately your report is rather imprecise for example information whether you talk about Email (HTML) Composer or Web Page Html composer, it is unclear whether you tested with a newly created unsaved or an existing document, ...

But I am pretty sure that this one is a DUP of "Bug 1427218 - Ver 2.49.1 does not allow for linking documents to web pages.", which is a DUP of "Bug 1417819 - Browsing files to insert image will not insert file path to "Image Location" line".

@Reporter: Thank you for your attention. 
Please feel free to reopen this Bug if you find out that the fix for the other bug (for SM 2.56!) does not solve your problem or if you see other well founded indication that you fond an independent bug.
In that case Please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273)
b) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a OOo or LibreOffice DRAW document and to add comments 
   that explain what you want to show (attach .png or PDF from source document)
c) add information 
c2) concerning your SM localization (UI language, Locale setting)
c4) how you launch SM (Double click on document? console? …)
c5) Whether problem persists in Safe Mode without add-ons
c6) Whether problem persists with blank new profile
c7) everything else crossing your mind after you read linked texts
d)  An URL for a web page where you observe the problem.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
OS: Unspecified → Mac OS X
Resolution: --- → DUPLICATE
Duplicate of bug: 1417819
You need to log in before you can comment on or make changes to this bug.