Wrong string order in Add Language dialog (when there are accented letters)

RESOLVED FIXED

Status

SeaMonkey
Preferences
--
minor
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Christian Tanguy, Assigned: Erik Fabert)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

The "Add Languages" dialog (communicator/pref/pref-languages.dtd) does not list
the languages(/country) in the correct order when dealing with accented letters
(correct order for most european countries... : the one used in the adress-book,
for example)


Reproducible: Always
Steps to Reproduce:
1. Use the de-AS language pack
2. Do Edit/Preferences (Bearbeiten / Einstellungen / Navigator / Sprachen /
Hinzufügen...)
3. Go to the "Arabisch/*"

Actual Results:  The order is "Algerien < Yemen < Ägypten"


Expected Results:  "Ägypten < Algerien < Yemen"

Comment 1

15 years ago
Reporter: can you confirm this, hopefully with a screenshot, on a modern build?
Summary: Wrong string order in Add Language dialog (when there are accented letters) → Wrong string order in Add Language dialog (when there are accented letters)
(Reporter)

Comment 2

15 years ago
Created attachment 125350 [details]
Screenshot for 1.4 beta

This is our bug on 1.4 beta, with the de-AT (german) language-pack. You see it
twice, for Dänisch and Österreich.

Comment 3

15 years ago
Don't see any dupes on this one.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
Though it may be related to 54746
Blocks: 54746
Product: Browser → Seamonkey
(Assignee)

Comment 5

14 years ago
Created attachment 172963 [details] [diff] [review]
Sort using localeCompare.

Small problem: localeCompare is very slow. This might cause a noticeable delay
on older machines.
Attachment #172963 - Flags: review?(smontagu)
*** Bug 163140 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Attachment #172963 - Flags: review?(smontagu) → review+
(Assignee)

Updated

14 years ago
Attachment #172963 - Flags: superreview?(neil.parkwaycc.co.uk)

Updated

14 years ago
Attachment #172963 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+

Comment 7

14 years ago
Comment on attachment 172963 [details] [diff] [review]
Sort using localeCompare.

mozilla/xpfe/components/prefwindow/resources/content/pref-languages.js 	1.35
Assignee: bugs → jerfa
(Assignee)

Comment 8

14 years ago
Fixed. I'll file a new bug with a suggestion to speed up the Add Languages
dialog when it's ready.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 9

13 years ago
Hello. I have filled bug 300759, which seems to be a regression of this one in
Firefox 1.1. Can anyone confirm this? If it's a regression, how must we do? Mark
a dependency between bugs or mark mine as duplicate and reopen this one?

Comment 10

13 years ago
(In reply to comment #9)
> Hello. I have filled bug 300759, which seems to be a regression of this one in
> Firefox 1.1. 

It's a separte bug. Apparently, Ben didn't incorporate the fix for this bug when
he mass-landed his ff 1.1 work as happended in several other cases. 

You need to log in before you can comment on or make changes to this bug.