History only goes back 100 items

RESOLVED DUPLICATE of bug 1269913

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1269913
14 days ago
13 days ago

People

(Reporter: zeko512, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 days ago
User Agent: Mozilla/5.0 (Linux; Android 7.0) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Focus/2.5 Chrome/55.0.2883.91 Mobile Safari/537.36

Steps to reproduce:

Normal web browsing (non-private). Happened to me in versions 57.0 and 52.4.1


Actual results:

Only last 100 history items are remembered. The rest is cut off as if I had set up the program to delete history periodically.
This is sometimes less than a day's browsing for me, and makes the whole history feature near useless to me.


Expected results:

I would like users to be able to adjust the number of items remembered, like in the desktop version with places.history.expiration.max_pages. The main reason why I tried Firefox for Android in the first place was to get rid of a similar (but actually less conservative) limit in another app that I used all the way since Froyo. I think my Nougat phone with 4GB RAM can handle a few (dozen) thousand items in history just fine (if the other app could handle a similar quantity of bookmarks with awesomebar-like functionality on Froyo).

Comment 1

13 days ago
Bug 1269913, although unfortunately that has slipped my mind somewhat.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269913
You need to log in before you can comment on or make changes to this bug.