Closed Bug 1428679 Opened 2 years ago Closed 10 months ago

"Use System Font Size" option on Android Firefox doesn't change the Bugzilla font size.

Categories

(bugzilla.mozilla.org :: User Interface, defect)

Production
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 101865

People

(Reporter: smartfon.reddit, Unassigned)

Details

Attachments

(1 file)

Attached image bugzilla.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

On Firefox Android, enable Firefox Settings > Accessibility > Use system font size.

On Android settings, change the display font size to Huge. Open any website and confirm that the text is Huge. Open Bugzilla - the text is still tiny. The Bugzilla page doesn't respect the Use System Font Size option anymore.

Another problem with Bugzilla on desktop (let me know if a separate bug report is needed). I use the Mouse Gesture Events extension. It's configured to do actions while swiping down, up, diagonal-up (jump to page top), diagonal-down (jumps to page down). The up and down works but the latter two don't. I believe there was a recent UI update on Bugzilla that could have played a role in this.
No idea if it was broken earlier, but right now font inflation seems to be working as usual on bugzilla.mozilla.org.
This is the font scaling on Brave Browser, Samsung Internet and Lightning Browser (with its textflow option enabled):  https://i.imgur.com/cRT6OfT.png

Font scaling on Firefox Release, Beta and Nightly: https://i.imgur.com/3rorGIh.jpg

This is how Bugzilla shows on Firefox Focus (w & w/o script blocker): https://i.imgur.com/iEm79M1.png
... and when I zoom-out to view the full page, it doesn't render the rest of the screen except for the  horizontal toolbar on the top: https://i.imgur.com/00D2QWd.jpg
Since Bugzilla's design is not responsive, such results are not surprising. Should be solved in Q2 this year.
Component: General → User Interface
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 101865
You need to log in before you can comment on or make changes to this bug.