Closed Bug 1428730 Opened 2 years ago Closed 2 years ago

Rendering issues on Amazon and Twitter with 4k screen

Categories

(Core :: Graphics: Layers, defect)

59 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 + fixed
firefox59 + fixed

People

(Reporter: ttaubert, Assigned: jnicol)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Whenever I load Amazon or Twitter either I see rendering issues immediately or when scrolling. The page is usually missing images, has black rectangles, or is painted twice from the top when scrolling down.

mozregression gave me the following:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ccd7b237c4337a00e45bf18ac2d0218c61e1134d&tochange=6b52d9870d2d16a29e3075627953304c574f11ed

This doesn't seem to be an issue on macOS, can't reproduce it there.
I confirmed locally that backing out [1] fixes the issue for me. What's confusing is that I can't reproduce this with a clean profile, it only happens with my default profile.

[1] https://hg.mozilla.org/integration/mozilla-inbound/rev/6b52d9870d2d16a29e3075627953304c574f11ed
Not affecting OS X makes sense, because it uses tiling rather than RotatedBuffer. If you post your about:support of the affected profile I might be able to see a pref change causing it.
Also, if you could set layers.dump=true then post the terminal output on amazon or twitter that would be really helpful. Thanks!
about:support has no strings unfortunately. The modified prefs aren't listed. I'll try to get you a layers dump.
(In reply to Tim Taubert [:ttaubert] from comment #4)
> about:support has no strings unfortunately. The modified prefs aren't
> listed. I'll try to get you a layers dump.

FTR, that too is due to the rendering issue reported here in this bug.
Wait, this wasn't uplifted yet.
Summary: Rendering issues on Amazon and Twitter → Rendering issues on Amazon and Twitter with 4k screen
Track 58+/59+ as bug 1417310 caused this regression and bug 1417310 has already been in Beta58.
Assignee: nobody → jnicol
Comment on attachment 8941123 [details]
Bug 1428730 - Allow surfaces up to a width or height of 16384.

Even at a 16384 limit we break things. I think we should revert bug 1417310
Attachment #8941123 - Flags: review?(bas) → review-
Bug 1417310 has been backed out from both branches.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.