Closed Bug 1428732 Opened 2 years ago Closed 2 years ago

Credit card - On www.mediamarkt.de credit card autofill doesn't work

Categories

(Toolkit :: Form Autofill, defect)

59 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: Ovidiu, Assigned: selee)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:V2][Misc.])

Attachments

(1 file)

Affected versions]:

Tested on Nightly 59.0a1(2018-01-07)

[Affected platforms]:

Tested on Mac OS X 10.12, Windows 10

[Steps to reproduce]:

Prerequisites:
 1. use VPN to connect to a Germany server. 
 
 STR:

1. Go to  www.mediamarkt.de and buy an item and proceed until you are in the credit-card section.
2. Double click on the "Karteninhaber" or "Kartennummer" fields. 


[Expected result]:

The autofill credit card suggestions are displayed. 

[Actual result]:

Nothing happens. 

NOTE: Here is a video of the actual result: https://streamable.com/ncr79
Whiteboard: [form autofill: V2]
Flags: needinfo?(selee)
Whiteboard: [form autofill: V2] → [form autofill:V2][Misc.]
Here is a list of the element's id/name in credit card page:

     cc-name:   creditCardHolder / creditCardHolder
   cc-number:               CCNr / CCNr 
 cc-exp-year:             KKYear / KKYear
cc-exp-month:            KKMonth / KKMonth

Our heuristics can only recognize card holder name based on its id/name.
We don't have the related regexps for others, and it's the root cause of this issue.
Flags: needinfo?(selee)
See Also bug 1428729.

It seems to me that we should start to consider adding "KKYear", "KKMonth", "CCNr" and "KKNr" to our rules as at least two German websites use these patterns. What do you think?
Flags: needinfo?(selee)
See Also: → 1428729
I think it's worth to try add these new rules for German websites. I am going to add these rules and see if there is any regression.
Assignee: nobody → selee
Status: NEW → ASSIGNED
Flags: needinfo?(selee)
Comment on attachment 8941354 [details]
Bug 1428732 - Add the credit card related rules for recongnizing cc-exp-year, cc-exp-month, and cc-number for German web sites.

https://reviewboard.mozilla.org/r/211672/#review217440
Attachment #8941354 - Flags: review?(lchang) → review+
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a3ef3fbcfc88
Add the credit card related rules for recongnizing cc-exp-year, cc-exp-month, and cc-number for German web sites. r=lchang
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a3ef3fbcfc88
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Hi Ovidiu, can you help to verify is issue resolved? Thank you.
Flags: needinfo?(ovidiu.boca)
Hello Lauren,

I tested this with FF Nightly 59.0a1(2018-01-12) and I can confirm that the credit card autofill suggestions are displayed. 
One thing that I noticed it's related to the expiration date of the card. Let's say that I file in this form with the data from one of my profiles, all the fields are updated accordingly, and when I want to clear the autofill form in the date field the data is not deleted, I think it should be reset to the initial state "MM" "JJJJ". Please see the screen recorder for a better understanding: https://streamable.com/e3c70

Please tell me your opinion about this, thanks.
Flags: needinfo?(ovidiu.boca) → needinfo?(yfu)
Hi Ovidiu,

What you saw is expected. According to UX Spec [1], it's by design that we won't reset a <select> element when clearing a form because it doesn't really help users.


[1] https://mozilla.invisionapp.com/share/AP8TFZ22G#/screens/252880119
Flags: needinfo?(yfu)
Thank Luke for clarifying UX spec. Hi Ovidiu, I agree with Luke that it's our expected behavior for select element. Can you help to check if there's another issue ?
Flags: needinfo?(ovidiu.boca)
I also verified this behavior on amazon.com, in the "Add New Payment Method" section and I have the same result. I think this is an expected behavior. I will mark this as verified fixed based on comment 11.
Status: RESOLVED → VERIFIED
Flags: needinfo?(ovidiu.boca)
You need to log in before you can comment on or make changes to this bug.