JRE SE 1.4 displays java.lang.NullPointerException for applets

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
major
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: shadytrees, Assigned: Joe Chou)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla 1.0 RC 1
BuildID:    2002041711

I have just downloaded JRE 1.4 with Mozilla 1.0 RC1. I copied the NP*.dll files
to the plugin folder as many sites have suggested (included Bugzilla). However,
for all Java applets, a java.lang.NullPointerException error occured and the
java applet never loads. It just displays a gray screen with the error on it. Is
this a problem with Mozilla or with the JRE? This error does not occur with JRE 1.3.

Reproducible: Always
Steps to Reproduce:
1.Download JRE and Mozilla 1.0 RC1.
2.Install JRE and Mozilla
3.Copy all files in the /bin of your JRE directory to the plugin folder of Mozilla.
4.Open a website with a java applet.


Actual Results:  An error window pops up with the error and the java applet
never loads.

Expected Results:  The java applet should've load without any errors.

Comment 1

16 years ago
wfm using build 2002050705 on Win2k (trunk) + JRE 1.4.0.
Don't copy all the files to plugins directory, NPOJI610.dll is enough.
Assignee: idk → joe.chou
Component: Java-Implemented Plugins → OJI
QA Contact: avm → pmac
(Reporter)

Comment 2

16 years ago
I did try loading java applets with only NPOJI610.dll but the
java.lang.NullPointerException still popped up.

Comment 3

16 years ago
WFM 2002042608 / JPI 1.4 / Windows 2000.

There is a problem with the applet painting the tabs, but that isn't what this
bug is about.

Comment 4

16 years ago
Win98, Moz Build 2002052306, JRE 1.4

I am having this problem. I had 1.4 before RC3 & don't remember seeing this in
RC2 or earlier. Wrt to comment #1, all 5 java dlls should be placed in plugins
folder. See current release notes or any of the umpteen Java-related bugs in
bugzilla. I will try uninstalling JRE1.4 & reinstalling to see if this clears
things up, then will come back and report...

Comment 5

16 years ago
Win98, Build ID 20020530012:

I uninstalled MozRC3 & JRE1.4 & then installed Moz1.0 & JRE1.4. Copied the
appropriate plugins into Moz's plugin folder and launched Mozilla. Went to
http://www.auburnalabama.org/library/ and received this error message for each
applet on the page. Haven't found a page w/ java in it that works yet. Highly
annoying...
(Assignee)

Comment 6

16 years ago
Tried it on winxp with moz1.0RC2 and ns7pr1, and it seem working OK. 
Is this a win98 only problem?
Reporter, have you tried on other Windows platforms?
(Reporter)

Comment 7

16 years ago
No I have not tried it on other platforms. However, after I installed JRE 1.3 and uninstalled it and installed JRE 1.4, it worked fine. I tried that process before but it never worked.

Comment 8

16 years ago
I still see this on Win98, Moz1.1a. Had to go down to JRE 1.3.1_03 in order to
see java applets...guess I'll be sticking w/ 1.3 for the time being. Is there
any advantage to using JRE 1.4 (if I were to get it working, that is)?

Comment 9

16 years ago
WFM on WinXP with BuildID 2002061408 and JRE 1.4.0-b92, so does seem to be
related to just win98.
The advantage of 1.4 is that it is supposed to be faster than 1.3

Comment 10

16 years ago
Do Win98 people have a similar problem with
https://banking.sonline.de/sparkasse-ac/ if so then this bug could be a dupe of
bug 114201
(Reporter)

Comment 11

16 years ago
Funny, after I uninstalled it and installed it again several times it worked. Try keeping Java Web Start which comes with JRE 1.4 and see if that works. Right now I have Mozilla 1.1a with JRE 1.4 and Java Web Start and Mozilla is working perfectly.

Comment 12

16 years ago
Could you close this bug as resolved works for me then please?
(Reporter)

Comment 13

16 years ago
Download Mozilla 1.1a or keep reinstalling JRE 1.4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.