Follow up Bug 1420393: SearchTest - Unsuccessfully entered WebPageLoading Intermittent error

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
RESOLVED FIXED
13 days ago
10 days ago

People

(Reporter: isabel_rios, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 days ago
testSearchEngine() is the only test still failing intermittently due to "Unsuccessfully entered WebPageLoading" error.

Lets try to find a solution for this one.
(Reporter)

Updated

12 days ago
Summary: Follow up Bug 420393: SearchTest - Unsuccessfully entered WebPageLoading Intermittent error → Follow up Bug 1420393: SearchTest - Unsuccessfully entered WebPageLoading Intermittent error
(Reporter)

Comment 1

12 days ago
I really don't understand why this test is still failing and only when it checks the amazon site. My guessing is that it is due to a timing issue checking the progress bar...but it is strange it only happens on amazon site and not in the rest of websites tested. 

After trying different solutions and not finding the root cause I would go for disabling the line that checks the amazon search engine at least to have the test passing till we come with a solution.

Would that be fine for you?
Flags: needinfo?(npark)
(Reporter)

Comment 2

12 days ago
Created attachment 8941152 [details] [review]
Pull Request
Attachment #8941152 - Flags: review?(npark)
I think it's because amazon is pretty heavy site to load. yes I agree with this approach.
Flags: needinfo?(npark)

Updated

12 days ago
Attachment #8941152 - Flags: review?(npark) → review+
(Reporter)

Comment 4

10 days ago
Thanks! Merged: https://github.com/mozilla-mobile/firefox-ios/commit/eee19705c7a53e61c1ecf895e95dd3b7a6b63f05
Status: NEW → RESOLVED
Last Resolved: 10 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.