Mozilla should support DHTML CSS filters, especially fliph

VERIFIED DUPLICATE of bug 64019

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 64019
16 years ago
16 years ago

People

(Reporter: Tsahi Asher, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; he-IL; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Currently Mozilla doesn't support these filters. the fliph filter is of special
importance for BiDi locales, where the whole UI is aligned to the right, because
in this situation the theme graphics don't make sense (arrows, sidebar tabs and
drop-down menues in modern theme, etc.) and need to be flipped horizontally. 

look at this page with Exploder 4+ to see how it should be.

Reproducible: Always
Steps to Reproduce:
1. go to http://www.w3schools.com/dhtml/tryit.asp?filename=trydhtml_filter
2. press the "display result" button
3. viola. nothing happens.

Actual Results:  text is displayed without styles

Expected Results:  "Glow" should glow, "Blur" should be blurred, etc. 
expecially, "Flip H" should be aligned to the right and mirrored: the F is on
the right end facing backwards (it's two horizontal lines are to the left of the
"leg"), and the same with the rest of the characters.
Duplicate of "rfe: implement the filter: style rule"

*** This bug has been marked as a duplicate of 64019 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
VERIFIED DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.