Closed Bug 1428873 Opened 2 years ago Closed 2 years ago

Tab favicon not changing when navigating to about:newtab

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1423256

People

(Reporter: christian, Assigned: pascalc)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180108100050

Steps to reproduce:

Firefox Nightly 59.0a1 (2018-01-08) on MacOS

## Method 1
1. Open a new tab (by default this brings you to about:newtab)
2. Open a page with a favicon
3. Navigate back

## Method 2
1. Open a page with a favicon
2. Navigate to about:newtab


Actual results:

The tab's favicon does not get updated. It shows the favicon of the page you navigated to before.


Expected results:

When navigating to about:newtab the tab's favicon should become the Firefox logo.
Worked in Firefox Dev 58.0b8.
Component: Untriaged → New Tab Page
Confirmed with  Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0 ID:20180110100224
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → pascalc
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1423256
You need to log in before you can comment on or make changes to this bug.