Embedding gray GC root tracing set/remove mismatch

RESOLVED DUPLICATE of bug 1369712

Status

()

Core
JavaScript: GC
RESOLVED DUPLICATE of bug 1369712
13 days ago
12 days ago

People

(Reporter: mccr8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 days ago
CycleCollectedJSRuntime::CycleCollectedJSRuntime calls:
  JS_SetGrayGCRootsTracer(aCx, TraceGrayJS, this);

but then CycleCollectedJSRuntime::Shutdown calls:
  JS_RemoveExtraGCRootsTracer(cx, TraceGrayJS, this);

It seems like the latter attempts to remove something from a different list. I don't actually see a JS_RemoveGrayGCRootsTracer function.

Updated

12 days ago
Status: NEW → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1369712
(Reporter)

Comment 2

12 days ago
Ah, right, I forgot about that quagmire.
You need to log in before you can comment on or make changes to this bug.