Closed Bug 1428988 Opened 5 years ago Closed 5 years ago

Beginning of roc's blog posts covered by blue with strict Tracking Protection

Categories

(Firefox :: Protections UI, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hsivonen, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: tp-needsrepro)

Attachments

(1 file)

Steps to reproduce:
 1) Navigate to any post on roc's blog, e.g. http://robert.ocallahan.org/2017/09/rr-trace-portability.html

Actual results:
The start of the post is covered by the background blue. (See attached screenshot.)

Expected results:
Expected the whole post to be readable.

Additional info:
The posts are readable in Chrome. In Firefox, the result doesn't depend on WebRender or on force-enabling GL layers without WebRender.
Hmmm.... I can't reproduce this with today's Firefox Nightly on both Linux and Mac... weird.

Hi Henri, could you provide more info about your platform environment?
Have you tried restarting Firefox with a clean profile or disable all your extensions? (try about:support page)
Flags: needinfo?(hsivonen)
Sorry about misattributing the bug and the failure to check a clean profile in the first place. This is due to enabling the strict list for Tracking Protection.

Moving over to Tracking Protection. Obviously, the point of the strict list is that it doesn't have compat compromises like the normal list. Still, it might be worthwhile to consider consider counter-measures for breakage of Blogger themes as Blogger is popular.
Component: Layout → Tracking Protection
Flags: needinfo?(hsivonen)
Product: Core → Firefox
Summary: Beginning of roc's blog posts covered by blue → Beginning of roc's blog posts covered by blue with strict Tracking Protection
I deleted an element in my blog theme to fix the problem.

Blogger is still somewhat broken though. It looks difficult to fix for the blog author.
Do we know which element/theme/tracker/etc. was responsible the breakage here?

(It'd be good to capture that information, for the benefit of whoever ends up coming up with mitigations here in the maybe-not-immediate future.)
Blocks: tp-breakage
Priority: -- → P3
Whiteboard: tp-needsrepro tp-content
Whiteboard: tp-needsrepro tp-content → tp-needsrepro
I think this is WORKSFORME for the moment, in the absence of a page that's still known to trigger the issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
See Also: → 1507024
You need to log in before you can comment on or make changes to this bug.