Status

Core Graveyard
Java: OJI
--
major
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: brian, Assigned: Joshua Xia)

Tracking

({hang})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When closing the browser window with http://www.ocad.ca/ loaded, mozilla and the
java plugin hang.

Steps to Reproduce:
1. open a browser window with any url
2. open another browser window and load http://www.ocad.ca/ or another page on
the site with a java applet
3. close the ocad window by clicking the 'X' in the top right corner.

The java plugin hangs and mozilla hangs. No talkback is generated.

Tested with mozilla 1.0RC1 and java plugin 1.3.1_02

Comment 1

16 years ago
what do you see in the java console before you hang?
can you try sun jre1.4 or ibm's jre?
Severity: critical → major
Keywords: hang
Summary: Crash closing window → Hang closing window
(Reporter)

Comment 2

16 years ago
nothing is output to the console window. I'm unable to test with other jre's
(sorry).
WFM: Using cvs trunk build from this morning on WinXP

Comment 4

16 years ago
Can confirm this bug with RC2 on WinMe and JVM 1.3.1_03

And I can reproduce it for at least one other url containing some extensive java
(the window popping up at https://www.1822direkt.com/onlineb.html)

BTW: I know this kind of bug (hang at closing window with java) since Netscape
4.5x or something. I can occaisonally reproduce it with Netscape 4.78 for the
URL mentioned above.

Comment 5

16 years ago
Does a brand spankin fresh trunk daily build help? (remote chance this is fixed
with bug 66748)

Comment 6

16 years ago
Retried it with Build 2002051408 on WinMe/JVM 1.3.1_03
Can still confirm the bug, and not a single line of output on console, even with
trace level 5.

On the other hand, the described procedure works fine if you open a new tab
instead of a new window, and then close the tab.

Comment 7

16 years ago
Syd, I think this is the one you are talking about, even I installed netscape 
6.2.3 with jre 1.3.1_02, go to htpp://mlslistings.com and enter the MLS#: 240677
and click on "View the Virtual Tour". Click on 'Play' button, and then click on
"360 Views", then close the "X" button. It then hangs!
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 8

16 years ago
Using the orginal url: http://www.ocad.ca with jre 1.3.1_02 netscape 6.2.3,
it doesn't hang anymore by closing the 'X' button.
Also, it also doesn't hang if using jre 1.4.0_01 (netscape branch build:
2002-08-23-10-1.0).

But it does hang on comment#7 by itself, and then install netscape branch build: 
2002-08-23-10-1.0)in different directory, choose "recommend' and don't select
Java, so it still uses the jre 1.3.1._02 instead, so the result is 
same as comment#7,while closing the "X' button, it hangs.

Since the orginal url of this bug is fixed, I'm going to change url:

Old url:  http://www.ocad.ca/
New url:  htpp://www.mlslistings.com
Keywords: nsbeta1

Comment 9

16 years ago
Please get the latest version of JRE for windows.Currently, the lastest version 
that bundles with netscape 7 is jre 1.4.0_01.
If you go to htpp://mlslistings.com and enter the MLS#: 240677
and click on "View the Virtual Tour". Click on 'Play' button, and then click on
"360 Views", then close the "X" button. It closes the browser without hanging.

Comment 10

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
Status: ASSIGNED → NEW
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen
(Assignee)

Comment 12

16 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 13

16 years ago
WFM on Linux(RH8.0)/Windows2000 with mozilla1.2 JRE1.4.1_01
Reporter: I just want to close this one. Feel free to reopen if you still can
reproduce this problem on latest JRE.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.