[Regression] Find From Menu is failing on iPad, next/previous buttons do not work

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
RESOLVED FIXED
13 days ago
3 days ago

People

(Reporter: isabel_rios, Assigned: garvan)

Tracking

({regression})

unspecified
Other
iOS
regression

Firefox Tracking Flags

(fxios?, fxios-v11.0 affected)

Details

Attachments

(2 attachments, 1 obsolete attachment)

8.37 KB, image/png
Details
55 bytes, text/x-github-pull-request
farhan
: review+
Details | Review | Splinter Review
(Reporter)

Description

13 days ago
Created attachment 8940992 [details]
Next_Previous Buttons.png

Seen on latest master: 903fbda9cc56e7f3c4d652c4bb76de6dd401e34f

Find From Menu test is not working on iPad. XCUITest failed because it is not possible to tap on Next button once you search for a word.
It is reproducible manually too on iPad sim.

Step:
- Go to https://www.mozilla.org/en-US/book/
- Tap on Page Options menu and select: Find in Page
- On the search bar type: Book
- Tap on the next (arrow down) button (see picture)

Actual
Nothing happens when tapping on it

Expected
The second Book word found should be selected and the counter increased from 1/6 to 2/6.

This seems to be introduced by the latest commit.
Failing on: https://github.com/mozilla-mobile/firefox-ios/commit/903fbda9cc56e7f3c4d652c4bb76de6dd401e34f

Latest working on previous commit: https://github.com/mozilla-mobile/firefox-ios/commit/0376ed2388463a7bc2fdff1d907b91da4cb13135
(Reporter)

Updated

13 days ago
Summary: [Regression] Find From Menu is failing in iPad → [Regression] Find From Menu is failing on iPad, next/previous buttons do not work
(Reporter)

Updated

13 days ago
Keywords: regression
(Reporter)

Comment 1

12 days ago
Please see bug 1420887, looks like due to its fixed this regression appeared
(Reporter)

Comment 2

10 days ago
More info here: tested on a real iPad device with latest nightly (8564) this issue is reproducible. 

And the close button on that search bar does not work either, it is not only the next/previous buttons that do not respond, looks like it is the whole search bar.
Hey Garvan, do you have time to take a look at this? 
This is a recent regression that breaks the entire "find in page" bar on iPad's. We should have this fixed before the first Beta 11.0 gets released.
Flags: needinfo?(gkeeley)
(Assignee)

Comment 4

7 days ago
I'll take a look
Assignee: nobody → gkeeley
Flags: needinfo?(gkeeley)
(Assignee)

Comment 5

7 days ago
Created attachment 8942672 [details] [review]
Pull request
Attachment #8942672 - Flags: review?(fpatel)
(Assignee)

Updated

7 days ago
Blocks: 1420887
(Assignee)

Comment 6

7 days ago
Comment on attachment 8942672 [details] [review]
Pull request

The stackview is supposed to have a max width, fixing patch.
Attachment #8942672 - Flags: review?(fpatel)
(Assignee)

Comment 7

7 days ago
Created attachment 8942685 [details] [review]
Pull request
Attachment #8942672 - Attachment is obsolete: true
Attachment #8942685 - Flags: review?(fpatel)
Attachment #8942685 - Flags: review?(fpatel) → review-
Attachment #8942685 - Flags: review- → review+
(Assignee)

Comment 8

3 days ago
landed on master
Status: NEW → RESOLVED
Last Resolved: 3 days ago
Resolution: --- → FIXED
(Assignee)

Comment 9

3 days ago
Follow up for Snackbar animation improvement: https://bugzilla.mozilla.org/show_bug.cgi?id=1431834
You need to log in before you can comment on or make changes to this bug.