Web based context menu displays twice when selected

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
12 days ago
6 days ago

People

(Reporter: emilghitta, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 wontfix, firefox58 affected, firefox59 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 days ago
Created attachment 8941028 [details]
more menu.gif

[Affected versions]:
59.0a1 (BuildId:20180108220132)
58.0b14 (BuildId:20180103230655)
57.0.4 (BuildId:20180103231032)

[Unaffected versions]:
52.5.3 esr (BuildId:20171226003912)

[Affected platforms]:
Windows 10 64bit.
Ubuntu 16.04 64bit.
macOS 10.12.

[Steps to reproduce]:
1. Launch Firefox with a clean profile.
2. Access the following link: https://app.nuclino.com/login.
3. Sign in with the following test account: emilgtesting@gmail.com (username) mozillatest (password).
4. Click on the "More" menu.

[Expected result]:
The menu opens smoothly.

[Actual result]:
A small glitch can be observed (The menu looks as if it is opening twice).

[Regression range]:

This seems to be a regression:

Last good revision: 19f92c04608cec275dab73e8acad5141de8a5c44
First bad revision: 57ff68e8e3fc476bbe5bc73addcca13bb5ce0097

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=19f92c04608cec275dab73e8acad5141de8a5c44&tochange=57ff68e8e3fc476bbe5bc73addcca13bb5ce0097

[Additional notes]:
For further details regarding this issue please observe the attached screencast.

Please feel free to change the product or component if necessary.
(Reporter)

Comment 1

12 days ago
Hi Gabriel, It seems that mozregression pointed out Bug 1384976 (which may have caused this regression).

Can you please have a look into this?

Thanks!
Flags: needinfo?(gl)
This css change in Bug 1384976 only changed the styles for the Rules view in devtools and should not affect normal Firefox activity. Clearing needinfo since my changes are not causing this regression.
Flags: needinfo?(gl)

Updated

11 days ago
Component: DOM: Events → DOM
Summary: [Nuclino] "More" menu glitches → Web based context menu displays twice when selected

Updated

11 days ago
status-firefox57: affected → wontfix
Has something happened with the app, I can't reproduce the effect you describe. I tested on my locally built version on linux, and 57 on Windows 10, both on fairly fast machines. Emil, do you still see it?
Flags: needinfo?(emil.ghitta)
(Reporter)

Comment 4

9 days ago
I can confirm that this issue is no longer reproducible. (Tried reproducing it with Fx 57 and Fx 59 using Windows 10 and macOS 10.11).
Flags: needinfo?(emil.ghitta)
Status: NEW → RESOLVED
Last Resolved: 6 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.