Closed Bug 1429202 Opened 4 years ago Closed 4 years ago

[UX] Address bar shows remote results before local ones (even tho they load later)

Categories

(Firefox :: Address Bar, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1426216

People

(Reporter: alex94puchades, Unassigned)

Details

Attachments

(1 file)

Attached image 2018-01-09.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

Entering any search query into the address bar (configured for both searching and navigation).


Actual results:

At first, local results are shown while remote ones are still being recollected. However, once remote search results arrive, they appear before local ones.


Expected results:

Remote search results should appear after local search results, because they appear later and in the meantime the user could have already started keyboard-navigating the dropdown list (it has happened to me a lot of times already)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Component: Untriaged → Address Bar
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1426216
You need to log in before you can comment on or make changes to this bug.