The "Save Link as" context menu option do not work in the "Firefox Notes" sidebar

VERIFIED FIXED in Firefox 59

Status

()

P2
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: mcoman, Assigned: past)

Tracking

Trunk
Firefox 59
Points:
---

Firefox Tracking Flags

(firefox57 wontfix, firefox58 wontfix, firefox59 verified)

Details

Attachments

(2 attachments)

Created attachment 8941394 [details]
rec of the issue.gif

[Affected versions]:
- Firefox 57.0.4 and up

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a Firefox profile with the latest version of the "Firefox Notes" add-on (2.2.0dev custom build from 01.10.2018) installed.
- Have a website link copied to clipboard.

[Steps to reproduce]:
1. Open the browser with the profiles from prerequisites.
2. Paste the link from prerequisites into the "Notes" sidebar.
3. Select the link and then right click on it.
4. Click the "Save Link as" context menu option and observe the behavior.

[Expected result]:
- The OS's specific dialog box is opened.

[Actual result]:
- Nothing happens.

[Notes]:
- Attached a screen recording of the issue.

Comment 1

a year ago
This doesn't work for a normal HTML page opened in the sidebar either. It's not a WebExtensions specific issue, moving over to Firefox.
Component: WebExtensions: Untriaged → General
Product: Toolkit → Firefox
Gijs, do you know if we have a bug on file for this already?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 3

a year ago
(In reply to Panos Astithas [:past] (please ni?) from comment #2)
> Gijs, do you know if we have a bug on file for this already?

bug 1285012 is the closest, though it doesn't mention this particular item. The context menu in the sidebar has long been iffy for many things. I don't know who would be a good person to go through and audit it in all its forms.

Bouncing this for you to be able to prio / assign someone / dupe / organize / etc. :-)
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(past)
Nice find! Based on Mike's work in that bug I have a pretty simple fix that seems to do the trick. Let's see what try thinks:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2cc60d4c6dd067bfd1e7e9b8a46d573061966809
Assignee: nobody → past
Status: NEW → ASSIGNED
Flags: needinfo?(past)
Priority: -- → P2

Comment 5

a year ago
(In reply to Panos Astithas [:past] (please ni?) from comment #4)
> Nice find! Based on Mike's work in that bug I have a pretty simple fix that
> seems to do the trick. Let's see what try thinks:
> 
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=2cc60d4c6dd067bfd1e7e9b8a46d573061966809

Lovely. Pre-emptive r=me on that patch (also, nice all-green try!).

Can we have a follow-up to add some tests for context-menu-in-sidebar stuff? I bet it's possible to adapt the current set of tests that we have for the content context menu so that they run the exact same tests against the sidebar as well, which might unearth more issues (though I'm not sure how many of the context menus we actually activate, I think we mostly check that their visibility/enabled state is updated correctly - that'd still be a win over the current state, though!)

Also, from auditing based on that change, looks like view partial source is also broken:

https://dxr.mozilla.org/mozilla-central/rev/c38d22170d6f27e94c3c53093215d20255fab27a/browser/base/content/nsContextMenu.js#884

I'll file a follow-up myself for that one.

Updated

a year ago
See Also: → bug 1430057
Comment hidden (mozreview-request)

Comment 7

a year ago
mozreview-review
Comment on attachment 8942252 [details]
Bug 1429364 - Fix 'Save Link As' context menu option in sidebars.

https://reviewboard.mozilla.org/r/212532/#review218246
Attachment #8942252 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 8

a year ago
Pushed by pastithas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/392278bcc755
Fix 'Save Link As' context menu option in sidebars. r=Gijs

Comment 9

a year ago
Woot! There's a lot more sidebar users these days thanks to WebExtensions.

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/392278bcc755
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox59: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
(In reply to :Gijs from comment #5)
> Can we have a follow-up to add some tests for context-menu-in-sidebar stuff?

Filed bug 1430281.
This behavior is no longer reproducible, now the "Save Link as" context menu option works in the "Firefox Notes" sidebar
Verified as fixed using latest Nightly 59.0a1 Build ID 20180114220708, on, Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12.
Status: RESOLVED → VERIFIED
status-firefox59: fixed → verified
Seems late for 58 (not a new bug, and we're at RC week), so I'll call this wontfix.
status-firefox57: affected → wontfix
status-firefox58: affected → wontfix
You need to log in before you can comment on or make changes to this bug.