Closed Bug 1429443 Opened 3 years ago Closed 3 years ago

Major painting issues with macOS High Sierra 10.13.2 on 52 ESR

Categories

(Firefox :: General, defect)

52 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1424945
Tracking Status
firefox-esr52 --- affected
firefox57 --- ?
firefox58 --- ?
firefox59 --- ?

People

(Reporter: mkaply, Unassigned)

Details

Attachments

(2 files)

Attached image Screenshot of problem
I upgraded from 10.13.1 to 10.13.2 and started seeing major painting issues with the ESR.

Black borders appear around windows and sometimes Windows don't paint at all.

See attachment.

This definitely seems to be 10.13.2 related.

It does not happen with the latest Firefox.
Summary: Major painting issues with macOS High Sierra 10.13.2 → Major painting issues with macOS High Sierra 10.13.2 on 52 ESR
I assume later versions aren't affected? Can you use mozregression --find-fix to figure out if there was a specific patch that avoids the bad behaviour in some way?

Note that the screenshot doesn't show any black borders that I can see - is that an artifact of the screenshot vs. what actually shows up to the user?
Flags: needinfo?(mozilla)
For some reason the black borders don't show in the screenshot. I've attached a photo from my camera.

I'm going to look at mozregression now. I was able to recreate on as recent as 56.
Flags: needinfo?(mozilla)
Great, that makes a lot of sense and is something we could uplift.
And there's already an uplift request in bug 1394654. I've added a comment.
Oh, it turns out we already knew about the 10.13.2 bug :(
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1424945
You need to log in before you can comment on or make changes to this bug.