Closed Bug 1429626 Opened 3 years ago Closed 3 years ago

toolbar button is flashing, and surplus repainting if WebRender enabled

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox59 --- disabled
firefox60 --- fixed

People

(Reporter: alice0775, Assigned: kvark)

References

Details

(Keywords: perf)

Attachments

(1 file)

Attached video screencast
toolbar button is flashing while page loading / when mouse moving

Reproducible: yes

Steps To Reproduce:
(prepare)
1. Enable webrender
   user_pref("gfx.webrender.enabled", true);
   user_pref("gfx.webrender.blob-images", true);
   user_pref("image.mem.shared", true);
   
(for example)
2. Make sure there is only home tab in 1st tab 
3. Open https://www.mozilla.org/en-US/firefox/nightly/firstrun/ in 1st foreground tab
4. Open http://forum.mozilla.gr.jp/ in the same 1st tab

5. Open https://login.opendns.com/?return_to=https%3A%2F%2Fdashboard.opendns.com%2F in 2nd foreground tab
6. Open http://www.getginger.jp/  in 3rd foreground tab
7. Switch to 1st tab and click Back button twice
8. Switch to 3rd tab (and click Reload button if need)
It seems that the toolbar is continuously/surplus repainting.

Mark as "perf"
Keywords: perf
Summary: toolbar button is flashing → toolbar button is flashing, and surplus repainting if WebRender enabled
As of the latest nightly, just need to set gfx.webrender.all to true.  This is related to a number of other bugs, probably the same root cause, but different ways to reproduce, so keeping them as non-duplicates.
Assignee: nobody → kvark
Priority: -- → P1
no longer reproduce on Nightly60.0a1.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.