Closed Bug 14297 Opened 21 years ago Closed 21 years ago

Account Wizard: Back button, loses old form values.

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: nbaca, Assigned: alecf)

References

Details

Build 1999091609M11: Win32/NT4
(Linux and Mac. Will check with more detail later)

Overview: These are various functional problems with the Account Wizard.
Account Setup Spec:
http://gooey/client/5.0/specs/mail/accountSetup/accountSetup.html

1. Problem: Identity page accepts any entry for Email Address (qatest32)
Expect: Should check for a valid email address (qatest32@netscape.com)

2. Problem: The Tab key isn't working.
Expect: The Tab key to advance the cursor to the next field.

3. Problem: With 1 POP account already created, create another account. Notice
that the Server dialog shows the option to enter another "Outgoing (SMTP)
Server".
Expect: If an account already exists and an Outgoing (SMTP) Server is already
defined then the Account Wizard's Server dialog should not show the option to
enter a second Outgoing (SMTP) Server.

4. Problem: Launch Account Wizard, enter account information, select the Next
button, then select Back button. All text boxes become blank.
Expect: After selecting the Back button all entries should be present for the
current session.
QA Contact: lchiang → nbaca
QA Contact to nbaca.
Status: NEW → ASSIGNED
Summary: Account Wizard: Functional Problems → Account Wizard: Back button, loses old form values.
Target Milestone: M11
#1 ids a dupe of #3744
#2 is a layout problem that really has nothing to do with me.
For #3, in PR1 I'm just going to show the text field anyway, but with the SMTP
server already entered. (I just fixed that this weekend)

Please open a seperate bug for #3, and I'll push it past PR1

#4 is still open, though I thought it was working. I'm changing the summary to
reflect that.
Blocks: 11091
(target milestone is M11 or M12 - add to beta tracking bug)
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
I think this was a bug with the text widget in this build (it was a little
flakey around that part of the week if I remember right)

it seems to be working for me on linux today, and I haven't changed any code....
this is probably a dupe of something like "editor text value can't be set" or
something, but I can't find that bug.

so instead I'm marking WORKSFORME
Depends on: 14146
Build 1999092309M11: NT4, Linux, Mac
- Issue #3 is fixed on all platforms
- Issue #4 is fixed on NT4 and Linux:
Once bug# 14146 is fixed on the Mac then I can try issue #4 on the Mac. If it
works then I can mark this bug verified.
Status: RESOLVED → VERIFIED
Build 1999110808M11: Mac 8.5.1 - All entries in Account Wizard are still present
after selecting the Back button.
Verified Fixed.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.