No accessability detection on Linux?

RESOLVED DUPLICATE of bug 239914

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 239914
10 days ago
6 days ago

People

(Reporter: pbone, Unassigned)

Tracking

({access})

Trunk
Unspecified
Linux
access
Points:
---

Firefox Tracking Flags

(firefox59 affected)

Details

(Reporter)

Description

10 days ago
I have heard it described that on Windows if you set a high contrast inverse theme for your desktop theme then Firefox will detect this and enable some accessability settings.  See Bug 1408121 comment 49.

This doesn't appear to work on Linux, I get firefox as normal (the menus, toolbars etc are painted in the correct desktop theme, but nothing else.  So my question, is this missing or am I just not noticing something.

Could this setting also be available via the about:preferences so that users can control it directly, whether or not it is detected on their OS.
(Reporter)

Updated

10 days ago
Keywords: access
Component: Untriaged → Disability Access

Comment 1

10 days ago
Hello Paul,

What is your version of Firefox? What is your GNU/Linux distribution? What is your desktop environment? Do you use a GTK3 or a GTK2 version of Firefox?

Here, on Debian 8 with Firefox ESR 52 compiled in GTK2 my Hight Contrast theme works correctly.

Best regards.
Flags: needinfo?(pbone)
(Reporter)

Comment 2

10 days ago
What is your version of Firefox? Nightly 59a1 2018-01-10
What is your GNU/Linux distribution? Linux Mint 18.1
What is your desktop environment? Cinnamon 3.2.7+serena
Do you use a GTK3 or a GTK2 version of Firefox? I don't know, whatever the normal version of Nightly uses.

The problem is I'm not sure what the expected behaviour should be.  Things are usually correct until they arn't (eg Bug 1429288) and I'm often told that there's special behaviour when a dark desktop theme is used (Bug 1408121 comment 49, and other times including IRL, usually referring to Windows).  It's sometimes said or implied that each accessability problem I have doens't _really_ happen for users with accessability things enabled, because the desktop theme is detected, I concluded that my desktop theme was not being detected and therefore I was having access issues.  But I don't actually know.
Flags: needinfo?(pbone)

Comment 3

9 days ago
(In reply to Paul Bone [:pbone] from comment #2)
> What is your version of Firefox? Nightly 59a1 2018-01-10
> What is your GNU/Linux distribution? Linux Mint 18.1
> What is your desktop environment? Cinnamon 3.2.7+serena
> Do you use a GTK3 or a GTK2 version of Firefox? I don't know, whatever the
> normal version of Nightly uses.

What is the exact name of the theme you're using?

Best regards.

ps: FYI, the latest release of Linux Mint is 18.3.
Flags: needinfo?(pbone)
(Reporter)

Comment 4

6 days ago
So my questions were answered in bug 1429288 comment 13 and this is already being tracked so this bug can close.

(In reply to Alex ARNAUD from comment #3)
> (In reply to Paul Bone [:pbone] from comment #2)
> > What is your version of Firefox? Nightly 59a1 2018-01-10
> > What is your GNU/Linux distribution? Linux Mint 18.1
> > What is your desktop environment? Cinnamon 3.2.7+serena
> > Do you use a GTK3 or a GTK2 version of Firefox? I don't know, whatever the
> > normal version of Nightly uses.
> 
> What is the exact name of the theme you're using?

Mint-Y-Dark

> 
> Best regards.
> 
> ps: FYI, the latest release of Linux Mint is 18.3.

Thanks, I'll investigate that.
Status: NEW → RESOLVED
Last Resolved: 6 days ago
Flags: needinfo?(pbone)
Resolution: --- → DUPLICATE
Duplicate of bug: 239914
You need to log in before you can comment on or make changes to this bug.