OnStopRequest is not always fired if a storage transport fails.

VERIFIED DUPLICATE of bug 142976

Status

()

Core
Networking: Cache
VERIFIED DUPLICATE of bug 142976
16 years ago
16 years ago

People

(Reporter: rpotts (gone), Assigned: rpotts (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
Sometimes when a storage transport is canceled (or fails in some other way) the
OnStopRequest(...) is NOT fired.  This can cause (among other things) the
throbber to keep going...

Steps to reproduce:
  1. Disable disk cache
  2. Load a large image... such as:
http://www.danheller.com/images/Models/Andrea/x-files-big.jpg
  3. hit the BACK button
  4. hit the FORWARD button.

Notice how the throbber NEVER stops.

*** This bug has been marked as a duplicate of 142976 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.