Closed Bug 1429754 Opened 2 years ago Closed 2 years ago

[Ubuntu] Floating-Point textures is required but not supported

Categories

(Core :: Canvas: WebGL, defect, P1)

59 Branch
x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- verified
firefox60 --- verified

People

(Reporter: emilghitta, Assigned: jgilbert)

References

Details

(Keywords: regression, Whiteboard: gfx-noted)

Attachments

(2 files)

Attached image issue3.png
[Affected versions]:
59.0a1 (BuildId:20180110221942)

[Unaffected versions]:
58.0b15 (BuildId:20180108140638)
57.0.4 (BuildId:20180103231032)
52.5.3 esr (BuildId:20171226003912)

[Affected platforms]:
Ubuntu 16.04 64bit.

[Steps to reproduce]:
1. Launch Firefox with a clean profile.
2. Access the following link: http://madebyevan.com/webgl-water/.

[Expected result]:
The animation starts successfully.

[Actual result]:
The animation doesn’t start playing and the following error is displayed:” Rendering to floating-point textures is required but not supported”

[Regression range]:

This seems to be a regression:

 Last good revision: 86318931910b1842ac8ca5ded448e0d6d0984343
 First bad revision: 2ba0c8df9a6786d5a70065b03ac66ffbe05695cb

 Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=86318931910b1842ac8ca5ded448e0d6d0984343&tochange=2ba0c8df9a6786d5a70065b03ac66ffbe05695cb


[Additional notes]:
For further details regarding this issue please observe the attached screenshot.
Hi Jeff!

Can you please have a look into this ?

Thanks!
Flags: needinfo?(jgilbert)
Duplicate of this bug: 1429740
So it turns out that COLOR_CLEAR_VALUE is, on some older drivers, clamped to [0,1] in glGet when the current draw-fb is non-floating-point. This would explain why I was seeing clamping that I was not expecting, but things otherwise seemed to work normally.

Let's remove the probe, remove the cached value check, and trust the driver.
Assignee: nobody → jgilbert
Flags: needinfo?(jgilbert)
Priority: -- → P1
Whiteboard: gfx-noted
Comment on attachment 8942027 [details]
Bug 1429754 - Trust the driver about floating point support. -

https://reviewboard.mozilla.org/r/212232/#review218014

lgtm.
Attachment #8942027 - Flags: review?(dmu) → review+
Duplicate of this bug: 1429941
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/add48ffcf303
Trust the driver about floating point support. - r=daoshengmu
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f6d0f79d687b
Trust the driver about floating point support. - r=daoshengmu
Flags: needinfo?(jgilbert)
https://hg.mozilla.org/mozilla-central/rev/f6d0f79d687b
https://hg.mozilla.org/mozilla-central/rev/9e0486fd4eec
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1429984
This issue is no longer reproducible using Firefox 59.0b5 (BuildId:20180128191456) and Firefox 60.0a1 (BuildId:20180129220114) on Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.