Dragging and Dropping a Top Site in the same position with the trackpad wrongly opens the site

VERIFIED FIXED in Firefox 59

Status

()

defect
P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: cmuresan, Assigned: Mardak)

Tracking

Trunk
Firefox 59
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 verified)

Details

Attachments

(2 attachments)

[Affected versions]:
- Firefox 59.0a1 Build ID 20180111100722

[Affected Platforms]:
- Mac 10.11 and 10.12

[Prerequisites]:
- Have a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a new profile.
2. Drag a Top Site to a different position and then drop it in its initial position.
3. Observe the behavior.
 
[Expected results]:
- Nothing happens.

[Actual results]:
- The site is opened.

[Notes]:
- The issue is not reproducible with a mouse.
- It seems like the issue was caused by bug 1428488.
- Attached a screen recording of the issue.
Assignee: nobody → rrosario
Priority: -- → P1
Assignee

Comment 1

a year ago
andreio reproduced this on 10.13.2
Assignee

Updated

a year ago
Iteration: --- → 59.4 - Jan 15
Assignee: rrosario → andrei.br92
Assignee

Comment 3

a year ago
Grabbed this after some discussion on irc
Assignee: andrei.br92 → edilee

Comment 4

a year ago
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/46d132fe5755a978604c05d832fa30758f020038
fix(topsites): Prevent mysterious trackpad clicks after dragging (#3941)

Fix Bug 1429825 - Dragging and Dropping a Top Site in the same position with the trackpad wrongly opens the site

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Assignee

Updated

a year ago
Blocks: 1431263
I have verified that the issue is no longer reproducible on the latest Nightly build (Build ID 	20180121220252) Mac 10.12 and 10.11.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.