Closed Bug 1429912 Opened 4 years ago Closed 4 years ago

Missing some saved passwords when synchronising both firefox and firefox beta on the same android device

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

Firefox 57
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1073680

People

(Reporter: michael-dev, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180104112904

Steps to reproduce:

1. verify that firefox beta has the interesting credentials in its stored passwords list (long-since present)
2. use firefox beta => settings => sync now and wait for "last sync before 0 minutes" to appear
3. start firefox (not beta) and find the interesting credentials missing in the stored password list
4. use firefox (not beta) => settings => sync now and wait for "last sync before 0 minutes" to appear
5. open list of stored passwords again but the interesting credentials are still missing
6. there is no master password involved.


Actual results:

The password I added in firefox beta does not show up in firefox.


Expected results:

The list of saved passwords should be the same in both firefox and firefox beta as they both synchronize with the same firefox sync account.
I verified using a fresh firefox on ubuntu that the interesting password has been synchronized by firefox android, as it is showing up after adding firefox on ubuntu to that firefox sync account.
Thanks for filing!

This seems like a subset of Bug 1073680, so I'll close this as a duplicate as work is going to happen there. Since about late Autumn we've had lower-than-usual password sync success rates; hopefully that'll be resolved soon. See also Bug 1404044.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
See Also: → 1404044
Duplicate of bug: 1073680
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.