Make ghost window unlinker e10s compatible

RESOLVED FIXED in Firefox 59

Status

()

P2
normal
RESOLVED FIXED
a year ago
5 days ago

People

(Reporter: mccr8, Assigned: mccr8)

Tracking

(Blocks: 1 bug)

unspecified
mozilla59
Points:
---

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
For debugging purposes, I added Cu.unlinkGhostWindows() a while ago that calls the Unlink() method on any ghost windows. I recently noticed that this isn't e10s compatible. Fixing that is simply a matter of sending a message to content processes.
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8942020 [details]
Bug 1429945 - Make ghost window unlinker e10s compatible.

https://reviewboard.mozilla.org/r/212228/#review218028
Attachment #8942020 - Flags: review?(bugs) → review+

Comment 3

a year ago
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/117e832dcd6e
Make ghost window unlinker e10s compatible. r=smaug
Priority: -- → P2

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/117e832dcd6e
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.