The "Alt+Shift+W" shortcut does not close the sidebar in "about: *" pages

VERIFIED FIXED in Firefox 59

Status

()

VERIFIED FIXED
a year ago
13 days ago

People

(Reporter: mcoman, Assigned: mconley)

Tracking

({regression})

Trunk
mozilla59
Unspecified
Windows
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 unaffected, firefox59 verified)

Details

Attachments

(2 attachments)

Posted image issue.gif
[Affected versions]:
- Nightly 59.0a1

[Affected Platforms]:
- All Windows

[Prerequisites]:
- Have the "Firefox Notes" experiment enabled from testpilot.firefox.com.
- Have the "Firefox Notes" sidebar opened.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Navigate to the "about:support" page.
3. Press the "Alt+Shift+W" keys and observe the behavior.

[Expected result]:
- The sidebar is closed.

[Actual result]:
- Nothing happens.

[Regression window]:
Last good revision: 59a75c1808ec67d20fd1eade0d3b4fc0e930454f
First bad revision: 24aa7ff25c3d4334234a103b718ba4b643a4e397
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=59a75c1808ec67d20fd1eade0d3b4fc0e930454f&tochange=24aa7ff25c3d4334234a103b718ba4b643a4e397

- It seems that the Bug 1423208 caused the regression.

[Notes]:
- This behavior is not encountered if the "Ctrl+B" and "Ctrl+H" shortcuts are used instead of the "Alt+Shift+W" one.
- The issue is no longer reproducible if the e10s is disabled.
- The issue is not reproducible on Mac and Linux.
- The issue is also reproducible with the TxP version of "Firefox Notes".
- Attached a screen recording of the issue.
Mike, do you know how Bug 1423208 could've caused this?
Flags: needinfo?(mconley)
(Assignee)

Comment 2

a year ago
I can reproduce the bug and regression range, so I'll take this.

I'm not certain why this is happening yet, but it was due to the first patch in my series which changed the default cached docShell active state in TabParent from false to true.
Assignee: nobody → mconley
Flags: needinfo?(mconley)
(Assignee)

Comment 4

a year ago
This patch reverts the first change in my patches for bug 1423208. This doesn't cause the permanent tab spinners to recur - this was something I thought made sense while I was in the area, but I guess I was wrong.

I'm rather sad to admit I don't fully understand why this broke things, but considering we shipped for so long with this default to false, I think the expedient solution would be to flip it back again. Perhaps someone with some spare cycles would be able to investigate, but I'm afraid I don't have any at this time. :/

Comment 5

a year ago
mozreview-review
Comment on attachment 8942351 [details]
Bug 1430072 - Make the TabParent's default cached value for the DocShell active state be false again.

https://reviewboard.mozilla.org/r/212632/#review218340
Attachment #8942351 - Flags: review?(nika) → review+
(Assignee)

Comment 6

a year ago
Thanks for the fast review! Holy smokes!

Comment 7

a year ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/373575d2ce71
Make the TabParent's default cached value for the DocShell active state be false again. r=mystor

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/373575d2ce71
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
This behavior is no longer reproducible, now the "Firefox Notes" sidebar can be closed using the "Alt+Shift+W" shortcut.
Verified as fixed using latest Nightly 59.0a1 Build ID 20180114220708, on, Windows 10 x64.
Status: RESOLVED → VERIFIED
status-firefox59: fixed → verified
status-firefox-esr52: --- → unaffected
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.