[Intermittent] Top Sites appear back in their original positions for a fraction of a second when they are moved

VERIFIED FIXED in Firefox 59

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
24 days ago

People

(Reporter: cmuresan, Assigned: rrosario)

Tracking

Trunk
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 unaffected, firefox58 unaffected, firefox59 verified)

Details

Attachments

(3 attachments)

[Affected versions]:
- Firefox 59.0a1 Build ID 20180111220102

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a clean new profile.

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open a new profile.
2. Drag and drop a Top Site to different positions (at least 5).
3. Observe the Top Site as it is dropped in each new position.
 
[Expected results]:
- The Top Site remains in that position.

[Actual results]:
- The top site will occasionally move back to its original position for a fraction of a second.

[Notes]:
- Attached a screen recording of the issue.
Assignee: nobody → rrosario
Iteration: --- → 59.4 - Jan 15
Priority: -- → P1
Bug 1428356 fixed a similar issue with holes but this is different.
See Also: → 1428356
Assignee: rrosario → khudson
Stealing back.
Assignee: khudson → rrosario
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/40ef01636dba346c9848db742cfcbf4a10e81035
fix(topsites): Avoid flickering to original state after drop (#3938)

Fix Bug 1430130 - Top Sites appear back in their original positions for a fraction of a second when they are moved
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1431263
I have verified that the issue is no longer reproducible on the latest Nightly build (Build ID 	20180121220252) using Windows 10 x64, Mac 10.12 and Ubuntu 14.04.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.