[IMAP] Double clicking on message loads an empty standalone window (if message hasn't been loaded yet)

RESOLVED DUPLICATE of bug 115343

Status

RESOLVED DUPLICATE of bug 115343
17 years ago
10 years ago

People

(Reporter: alex, Assigned: mscott)

Tracking

({polish})

Trunk
x86
Windows 2000
polish

Firefox Tracking Flags

(Not tracked)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020507
BuildID:    2002050708

In MailNews, I have a 3-pane setup: the left pane shows my folders, the
top-right shows the list of messages, and the bottom-right is the preview pane.
If I double-click on one of the messages (without having previewed it first),
the standalone message window will be blank. 

Reproducible: Always
Steps to Reproduce:
1. I only have IMAP accounts, so this may be an IMAP-only occurance
2. Load MailNews
3. Choose a message that you haven't read yet, in the preview-pane or otherwise.
It's important that Mozilla hasn't downloaded the message yet from the IMAP server.
4. Double-click on the message

Actual Results:  Standalone window loads, but the area for the message-body is
blank and the throbber spins indefinitely (the standalone window's toolbar and
ther message headers load fine in the standalone window).

Expected Results:  Message (headers and body) is loaded in the standalone window.

I'm not sure if it points to any clues, but if the message is viewed in the
preview pane first, then double-clicking on the message loads it into the
preview pane just fine. 

Related bugs: bug 58520 (?), bug 107010 (?)

Updated

17 years ago
QA Contact: olgam → huang
Hmm. On second thought, this probably shouldn't be in "Front End". 

-> IMAP
Assignee: sspitzer → mscott
Component: Mail Window Front End → Networking: IMAP
Keywords: polish

Comment 2

16 years ago
works for mw

Comment 3

16 years ago
WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Reopening. Still occurs with 2002091309 (Win2k). 

When attempting to trigger this bug, be sure to try double-clicking on a
previously-unread message (on that hasn't been downloaded from the IMAP server yet).
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

16 years ago
I have test the bug again according to your comments, but i still can nor reproduce.

when I double clike a unread message, mozilla activiate a new standalone
windown, the body of the message also displayed correctly.

trunk: 20020909
leon: Which OS are you using? 

And, the trick here is to have a "fast" double-click. With a slower
double-click, the message is loaded after the first click (though the
double-click still triggers the stand-alone window). 

With a quick double-click, the stand-alone window is loaded right away, and ends
up blank (continually "loading" even after the preview pane loads the message).

Perhaps is machine-speed also a factor? I'm testing on an Athlon 700, which may
be a bit slow by today's standards ;).

Comment 7

16 years ago
I am using a dell pc(cpu: 1.8G hz),and os is win2000.  
others also test this bug, and not reproduce too.

:)
leon: I think CPU speed is the factor at work. For instance, with my work
machine ( a 2 GHz Pentium), I can't reliably reproduce this -- it's probably not
possible there to double-click fast enough. 

However, see if you can find a sub-1GHz machine (or close to 700 MHz, ideally).
I think you'll be able to reproduce it there.

Comment 9

16 years ago
This bug frequently happens to me (not 100% be so) in case that the time between
moving focus on the mail thread and ouble-click on it is short enough.
It is not easy to measue what is "short enough". In my experience if double
clicking comes before the preview pane rendering completed, it is very possilble
you will get an empty window with the status bar howing "Loading Documents..."
and progress bar always scrolling but
you can only see nothing no matter how long you wait... 
To the time gap refered above, IMHO the network transfering is more possilbe a
bottleneck than that of CPU. 
Appears to be a dupe of bug 115343.

*** This bug has been marked as a duplicate of 115343 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.