Typo in nsXmlRpcClient.js line 94

RESOLVED FIXED

Status

()

Core
XML
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Adam Fletcher, Assigned: Samuel Sieb)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

684 bytes, patch
Heikki Toivonen (remove -bugzilla when emailing directly)
: review+
Heikki Toivonen (remove -bugzilla when emailing directly)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Line 94 reads:

throw Components.Exceptions('Only HTTP is supported');

It should read:

throw Components.Exception('Only HTTP is supported');

The extra "s" on Exception causes an error when init'ing the XML-RPC client.
It looks liks the solution is to remove the "s" - i've searching through the
rest of the file and no other calls to Components.Exceptions exist, but plenty
of Components.Exception calls exist. I am also using the modified version for my
company's app and it works fine.
(Reporter)

Updated

16 years ago
Summary: Typo in nsXmlRpcClient.js line 95 → Typo in nsXmlRpcClient.js line 94

Comment 1

16 years ago
Created attachment 82811 [details] [diff] [review]
patch
Reassigning to owner of XML-RPC.
Assignee: heikki → samuel

Comment 3

16 years ago
Marking NEW as it has a patch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch
(Assignee)

Comment 4

16 years ago
Why are you even hitting that line?

r=samuel@sieb.net
heikki, can you sr?
Why do we hit it, and what does it hurt?

Comment 7

16 years ago
We hit it when someone (say, an enduser, or someone writing an application using
XML-RPC) tries to use XML-RPC with a protocol other than http, say https.  

Just because the typo is in an error handler doesn't mean it shouldn't be fixed.
 Someone, sooner or later, will hit this error case.
(Assignee)

Comment 8

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

15 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.