Closed Bug 1430417 Opened 2 years ago Closed 2 years ago

Leakcanary is enabled in official builds

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

59 Branch
All
Android
defect
Not set

Tracking

(firefox57 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: JanH, Assigned: nalexander)

References

Details

(Keywords: regression)

Attachments

(1 file)

Showing up in my app drawer, belonging to the official Nightly build I've got installed, and also mentioned in https://www.reddit.com/r/firefox/comments/7q54b3/leaks_app_in_the_app_drawer_on_android/
Flags: needinfo?(nalexander)
(In reply to Jan Henning [:JanH] from comment #0)
> Showing up in my app drawer, belonging to the official Nightly build I've
> got installed, and also mentioned in
> https://www.reddit.com/r/firefox/comments/7q54b3/
> leaks_app_in_the_app_drawer_on_android/

This ain't right.  This must be because Leakcanary by default is enabled for debug builds, and we mutate a debug build into our shipping build.  (That should get better post Android-Gradle 3.0+, but that just bounced -- https://bugzilla.mozilla.org/show_bug.cgi?id=1411654.)

I'm surprised this made it through my APK comparisions when moving to Gradle -- I'll investigate.
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
Comment on attachment 8942980 [details]
Bug 1430417 - Do not include LeakCanary in automation builds.

https://reviewboard.mozilla.org/r/213248/#review218988
Attachment #8942980 - Flags: review+
Pushed by nalexander@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f5c4825b6ae8
Do not include LeakCanary in automation builds. r=jchen
https://hg.mozilla.org/mozilla-central/rev/f5c4825b6ae8
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
(In reply to Marcia Knous [:marcia - use ni] from comment #6)
> Presumably crashes such as
> https://crash-stats.mozilla.com/report/index/85c2eef8-575f-4cc1-a52c-
> e0fc20180116 will go away when this is taken out.

Yes, I expect so.  The window in which we shipped LeakCanary was short -- perhaps only one or two Nightly builds.
Flags: needinfo?(nalexander)
Comment on attachment 8942980 [details]
Bug 1430417 - Do not include LeakCanary in automation builds.

Seems fine, but jchen was quicker.
Attachment #8942980 - Flags: review?(jh+bugzilla)
Backed out along with bug 1411654 because of bug 1431140. I'm reopening this bug for now, but feel free to close it again as WONTFIX if you intend to just roll this fix into bug 1411654 when it re-lands instead.

https://hg.mozilla.org/mozilla-central/rev/90814e6a3ebb
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 59 → ---
This was addressed as part of the reland of https://bugzilla.mozilla.org/show_bug.cgi?id=1411654.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 60 → mozilla60
Version: Firefox 59 → 59 Branch
You need to log in before you can comment on or make changes to this bug.