Closed Bug 1430471 Opened 5 years ago Closed 2 months ago

Display grid-template-areas value on multiple lines in the rules view

Categories

(DevTools :: Inspector: Rules, enhancement, P3)

58 Branch
enhancement

Tracking

(firefox107 fixed)

RESOLVED FIXED
107 Branch
Tracking Status
firefox107 --- fixed

People

(Reporter: mike, Assigned: rfemailtesting)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36

Steps to reproduce:

The CSS Grid spec allows for you to create grid-template-areas in an ascii-art style matrix.


Actual results:

The issue is that when displaying the value for this property, devtools will output this onto one line. The same problem can also be caused by CSS minification . 
  


Expected results:

A proper solution would be to show each string on its own line, when displaying rules for grid-template-areas.
Helpful links:
MDN Docs for grid-template-areas: https://developer.mozilla.org/en-US/docs/Web/CSS/grid-template-areas
Codepen to mess around with: https://codepen.io/rachelandrew/pen/oXKgoQ
Severity: normal → enhancement
Component: Untriaged → Developer Tools: CSS Rules Inspector
Blocks: dt-grid
Priority: -- → P3
Summary: [Feature Request DevTools] Display grid-template-areas value on multiple lines in dev tools → Display grid-template-areas value on multiple lines in the rules view
Product: Firefox → DevTools
Assignee: nobody → rfemailtesting
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Severity: normal → S3
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a397692ab31
[devtools] Display grid-template-areas value on multiple lines. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
You need to log in before you can comment on or make changes to this bug.